Go Back   Jeep Garage - Jeep Forum > Search Forums

Join Jeep Garage Today
Showing results 1 to 8 of 8
Search took 0.01 seconds.
Search: Posts Made By: sergioad89
Forum: Engine Performance/Intake/Exhaust 06-20-2012, 08:40 AM
Replies: 8
Views: 1,845
Posted By sergioad89
Re: Can I mix High mileage Full synthetic with regular High Mileage?

Ok, I also got K&N Performance Gold oil filter, was that a good choice?
Forum: Engine Performance/Intake/Exhaust 06-20-2012, 05:58 AM
Replies: 8
Views: 1,845
Posted By sergioad89
Can I mix High mileage Full synthetic with regular High Mileage?

I will be doing my first oil change today... I've always gone to the 10 minute shops before and with a:

4.0L Laredo with 115k miles,

My concern is: I bought Mobil Super High Mileage 10w-30 (5...
Forum: Troubleshooting/Problems 06-15-2012, 08:30 AM
Replies: 8
Views: 490
Posted By sergioad89
Re: 01 auto 4.0 - CEL after fill-up?

Update:

Last night, the CEL went off, and the car ran like before... great shifting, great speed, great acceleration..

However, when doing the key dance, it still shows P 1762.

Why is that?
Forum: Troubleshooting/Problems 06-14-2012, 09:56 PM
Replies: 8
Views: 490
Posted By sergioad89
Re: 01 auto 4.0 - CEL after fill-up?

The code shows up in odometer... P1762. Only one this time...

Gov. and Solenoid were from junker. :(
Forum: Troubleshooting/Problems 06-14-2012, 11:33 AM
Replies: 8
Views: 490
Posted By sergioad89
Re: 01 auto 4.0 - CEL after fill-up?

The first time, mechanic cleaned some plug/cable that went from transmission to somewhere (engine?), and after that the car ran like before.

Second time, same symptoms, he replaced the cable from...
Forum: Troubleshooting/Problems 06-14-2012, 10:36 AM
Replies: 8
Views: 490
Posted By sergioad89
Re: 01 auto 4.0 - CEL after fill-up?

Last 2 times I pulled code, it was P1757 and P1762/3 codes.

I'll check codes today when I get home, but what if they are those 2 codes again?
Forum: Troubleshooting/Problems 06-14-2012, 09:12 AM
Replies: 8
Views: 490
Posted By sergioad89
Thumbs up 01 auto 4.0 - CEL after fill-up?

I'm not an expert or mechanic, but I think I know most terms by now because I've had this problem for a while now...

Here is the brief: Sunday I filled up the tank, and ti ran fine for 55 miles,...
Forum: Troubleshooting/Problems 06-01-2012, 01:04 PM
Replies: 1
Views: 1,105
Posted By sergioad89
Angry P1757 and P1762 - 2001 4.0 Automatic

Also got some "Valve Power Feed Malfunction"

Replaced gov. sensor, kick down cable seems to be "loose" or "broken"? (I tighten it and pedal feels sturdy, but after a bit, the pedal seems to become...
Showing results 1 to 8 of 8

 
Forum Jump

All times are GMT -5. The time now is 08:34 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.