Go Back   Jeep Garage - Jeep Forum > Search Forums

Join Jeep Garage Today
Showing results 1 to 40 of 59
Search took 0.01 seconds.
Search: Posts Made By: Triplecrown
Forum: Troubleshooting/Problems 04-22-2014, 03:11 PM
Replies: 4
Views: 218
Posted By Triplecrown
Re: Please help! Leak from underneath. 2006 WK 3.7-Solved!!

Problem solved.

I took it to the shop and they called me back, informing me that the oil pan rusted out, hence the leak.

I'm too busy to wrench on it right now, so I ok'd them to do the work.
...
Forum: Troubleshooting/Problems 04-21-2014, 11:01 PM
Replies: 4
Views: 218
Posted By Triplecrown
Re: Please help! Leak from underneath. 2006 WK 3.7

kennzz: I did just that earlier today, and the drops reappeared.
Forum: Troubleshooting/Problems 04-21-2014, 10:50 PM
Replies: 4
Views: 218
Posted By Triplecrown
Please help! Leak from underneath. 2006 WK 3.7

My WK has had a smell lately that resembles burning oil smell. I looked underneath and could see some drips on the rear part of the skid plate under the engine. I wiped it with my finger and cannot...
Forum: Engine Performance/Intake/Exhaust 01-17-2014, 12:10 PM
Replies: 7
Views: 431
Posted By Triplecrown
Why do I see oil below the oil filter location?

I've been noticing a small amount of oil below the oil filter (where the oil runs down the 'ramp') lately. I have wiped it off, and a few days later I can see where more has ran down it. I checked...
Forum: Troubleshooting/Problems 01-17-2014, 12:04 PM
Replies: 1
Views: 280
Posted By Triplecrown
Replacing Hood Release Handle & access??!!

I went to 'pop' the hood on my WK and the metal cable and hood release handle separated. After looking at the backside of the release handle I can see that it broke, where it holds the cable in...
Forum: Troubleshooting/Problems 11-29-2013, 03:52 PM
Replies: 6
Views: 393
Posted By Triplecrown
Re: Blowing Resistor packs

I replaced the connector/plug, have not had a problem since.
Forum: Troubleshooting/Problems 11-29-2013, 12:45 PM
Replies: 1
Views: 288
Posted By Triplecrown
Best way to remove 02 sensor, from my '06, 3.7/WK

I think I am going to replace the bank 1, sensor 2 O2 sensor. I am getting code P0137. Any tips on how to remove this sensor? I know they can be stubborn at times. Also, is it a somewhat easy...
Forum: Troubleshooting/Problems 11-29-2013, 12:41 PM
Replies: 4
Views: 1,045
Posted By Triplecrown
Re: O2 sensor problem? Getting code P0137...

Is there any particular reason why you came to my thread, just so you could give a shout out to 'fnky'? Try showing some respect and send a private message to 'fnky', instead of thread bombing me.
Forum: Troubleshooting/Problems 11-29-2013, 12:55 AM
Replies: 4
Views: 1,045
Posted By Triplecrown
O2 sensor problem? Getting code P0137...

Well, my 2006 jeep WK is throwing P0137 code, O2 sensor bank 1 sensor 2. Will replacing the 02 sensor fix the issue?

Also which sensor is Bank 1 sensor 2? before the cat or after? and which side?...
Forum: Technical Tips/DIY/How-To 11-02-2013, 02:44 PM
Replies: 5
Views: 959
Posted By Triplecrown
Best way to clean engine compartment?

Hello-

I would like to clean my engine compartment. Can I just power wash it at the car wash? Is there anything I need to cover up or protect? What is the best way to spiff up my engine...
Forum: Troubleshooting/Problems 10-29-2013, 10:22 AM
Replies: 2
Views: 346
Posted By Triplecrown
Key replacement - 06 wk

My wife lost her set of keys. Now we're down to only one key for the WK. The dealership is quoting some crazy numbers! ($245 includes programming)

What is a fair price? Is this something a...
Forum: Troubleshooting/Problems 10-24-2013, 02:00 PM
Replies: 0
Views: 888
Posted By Triplecrown
Code P0137 02 Circuit Low Voltage (Bank 1, Sensor 2)

CEL came on . I pulled code P0137, 02 Circuit Low Voltage (Bank 1 Sensor 2).

What does this mean? Where is this 02 sensor located? What can be done to fix this issue?

I turned off the CEL with...
Forum: Suspension/Brakes/Wheels/Tires 09-11-2013, 10:10 AM
Replies: 21
Views: 4,093
Posted By Triplecrown
Re: Thump/clunking sound only when going over bumps..

I took my 2006 GC to Belle Tire and they had it ready for me to pick up in a few hours. They gave me new sway links and bushings for the front for less than $250!
Forum: Troubleshooting/Problems 09-03-2013, 03:31 PM
Replies: 9
Views: 297
Posted By Triplecrown
Re: AC/Heat works on high only...

Update: I replaced the blower motor transistor, and everything seems fine.
Forum: Troubleshooting/Problems 09-02-2013, 12:24 PM
Replies: 9
Views: 297
Posted By Triplecrown
Re: AC/Heat works on high only...

Thanks! Do I get the resistor with or without Automatic Temp Control?
How do I know which one I have?
Forum: Troubleshooting/Problems 09-02-2013, 12:19 PM
Replies: 9
Views: 297
Posted By Triplecrown
Re: AC/Heat works on high only...

Huh? Are we talking about the same part? I can get them all day long for under $15 bucks.
Forum: Troubleshooting/Problems 09-02-2013, 11:17 AM
Replies: 9
Views: 297
Posted By Triplecrown
Re: AC/Heat works on high only...

Can a bad resistor board cause slight melting anywhere on the 'plug in' that connects to the resistor?
Forum: Troubleshooting/Problems 09-02-2013, 10:36 AM
Replies: 9
Views: 297
Posted By Triplecrown
AC/Heat works on high only...

My 2006 WK has been giving me some trouble regarding the AC/Heat. Sometimes the AC or heat will suddenly turn off or not come on at all, except if it is on the 'high setting'.

I got behind the...
Forum: Troubleshooting/Problems 06-21-2013, 05:37 PM
Replies: 3
Views: 1,066
Posted By Triplecrown
Re: "Programming Active" Light displayed on EVIC

My wife pulled the Jeep out of the garage as I was getting ready. When I came outside, I hopped in and shut the Jeep off and gave her keys back and used my keys instead. This happened approx an hour...
Forum: Troubleshooting/Problems 06-21-2013, 05:22 PM
Replies: 3
Views: 1,066
Posted By Triplecrown
"Programming Active" Light displayed on EVIC

Hello friends,

Today I noticed the words 'programming active' displayed on the EVIC. What does this mean? IT even stayed on for a moment after I took the key out.

Also, I have not replaced any...
Forum: Grand Cherokee - WK 03-28-2013, 11:16 AM
Replies: 25
Views: 1,127
Posted By Triplecrown
Re: Got My First Jeep!

Still a high price, even for 2011. Maybe because I live outside the Motor City, that vehicles are less.
Forum: Grand Cherokee - WK 03-26-2013, 06:25 PM
Replies: 25
Views: 1,127
Posted By Triplecrown
Re: Got My First Jeep!

NEVER have mercy on a salesman. 'Personable' or not. ;)
Forum: Grand Cherokee - WK 03-26-2013, 06:22 PM
Replies: 25
Views: 1,127
Posted By Triplecrown
Re: Got My First Jeep!

Congrats on getting your first WK! Here is some free advice-

1) Make sure you have a good relationship with a shop/mechanic/dealership. You're gonna be seeing a lot of each other.

2) Have a...
Forum: Troubleshooting/Problems 03-23-2013, 11:19 PM
Replies: 11
Views: 3,798
Posted By Triplecrown
Re: Transmission Problem? Stays in one gear, won't shift, no response from autostick.

Are you absolutely positive, about that? I could be wrong, but I was under the impression that some 2007 WK's had a LIFETIME powertrain warranty!!

Have you talked to the dealership? You can also...
Forum: Troubleshooting/Problems 03-23-2013, 10:22 AM
Replies: 11
Views: 3,798
Posted By Triplecrown
Re: Transmission Problem? Stays in one gear, won't shift, no response from autostick.

UPDATE: Problem Solved!! The lead frame assembly, containing the input speed sensor and a few other sensors, had to be replaced. The lead frame assembly contains wires and a circuit board. The valve...
Forum: Troubleshooting/Problems 03-20-2013, 09:41 PM
Replies: 13
Views: 3,462
Posted By Triplecrown
Re: Leaks when it rains

I have a similar issue! Mine leaks on the driver side (A-Pillar) where the grab bar is, and the water comes out where the 'screw cover' is. What makes mine tough to diagnose is it does not leak every...
Forum: Grand Cherokee - WK 03-20-2013, 05:21 PM
Replies: 4
Views: 595
Posted By Triplecrown
Forum: Grand Cherokee - WK 03-20-2013, 11:16 AM
Replies: 4
Views: 595
Posted By Triplecrown
Re: Confused about spark plug gap requirements for my 3.7! .040? Input, please.

0.44 is the number I'm hearing the most. BUT...the sticker under the hood is calling for .040

I have saw multiple gap requirements from JEEP that contradict each other.

This is why I'm reaching...
Forum: Grand Cherokee - WK 03-19-2013, 10:28 PM
Replies: 4
Views: 595
Posted By Triplecrown
Confused about spark plug gap requirements for my 3.7! .040? Input, please.

I'm near finished with my 60K mile service! Spark plugs are the only thing left on my list. I'm going to be installing NGK V Power ZFR6F11G. I'm getting multiple people telling me different gaps! The...
Forum: Grand Cherokee - WK 03-18-2013, 12:32 PM
Replies: 19
Views: 1,533
Posted By Triplecrown
Re: Looking at 2006 cherokees

How much did the lead frame and connector run you?
Forum: Engine Performance/Intake/Exhaust 03-17-2013, 11:26 PM
Replies: 1
Views: 961
Posted By Triplecrown
Fuel induction service...have you ever had it done?

What exactly IS fuel induction service? Does anyone recommend it? Is it another name for fuel injector cleaning? My service adviser at the dealership never brings it up, but I can see it on their...
Forum: Grand Cherokee - WK 03-17-2013, 11:08 PM
Replies: 19
Views: 1,533
Posted By Triplecrown
Re: Looking at 2006 cherokees

Sounds like me! I recently had my electronic shift module replaced and my WK s sitting at the dealership as we speak getting the lead frame assembly (which contains the input sensor) replaced! Thank...
Forum: Grand Cherokee - WK 03-17-2013, 10:59 PM
Replies: 7
Views: 735
Posted By Triplecrown
What are you paying for service/maintenance? Here is a price list from the dealership

What are you paying for service such as factory recommended and dealer recommended? Below is a price list from the dealership that does work on my WK, when needed. I actually have a good relationship...
Forum: Troubleshooting/Problems 03-16-2013, 04:11 PM
Replies: 4
Views: 914
Posted By Triplecrown
Re: Have you ever heard of this 'part' - "Lead Frame Assembly"Plus Update on prior th

This helps. Thank You, for taking the time to read and reply. :)
Forum: Troubleshooting/Problems 03-16-2013, 04:05 PM
Replies: 4
Views: 914
Posted By Triplecrown
Re: Have you ever heard of this 'part' - "Lead Frame Assembly"Plus Update on prior th

Hi dr-

I have the Quadra I. If that helps. I cannot select what range for the 4X4.
It is always in high range 4x4. What I wanted to know, is if the pan, fluid and filter would need to be changed,...
Forum: Troubleshooting/Problems 03-15-2013, 07:15 PM
Replies: 4
Views: 914
Posted By Triplecrown
Have you ever heard of this 'part' - "Lead Frame Assembly"Plus Update on prior thread

I took my WK to the dealership today because I was experiencing a shifting issue that involved my WK to act like it would not shift, the RPMS would climb and the trans range indicator on the...
Forum: Grand Cherokee - WK 03-08-2013, 11:11 PM
Replies: 34
Views: 3,172
Posted By Triplecrown
Re: Jeep WK reliability

As far as looks, I love my WK. I just bought mine this past December and so far I have had to replace the shift bezel and lately I have been having intermittent shift problems.

I quit smoking and...
Forum: Troubleshooting/Problems 03-08-2013, 08:24 PM
Replies: 11
Views: 3,798
Posted By Triplecrown
Re: Transmission Problem? Stays in one gear, won't shift, no response from autostick.

Today, I cleared the stored codes, so we'll see what happens. So far, everything has been good today, no problems.
Forum: Troubleshooting/Problems 03-08-2013, 02:13 AM
Replies: 11
Views: 3,798
Posted By Triplecrown
Transmission Problem? Stays in one gear, won't shift, no response from autostick...

When I went to drive my 06 WK, 3.7, 4x4 and as I began driving, I noticed the rpm's climbing and it did not shift, and seemed like it was 'stuck' in whatever gear it was in. The 'autostick' had no...
Forum: Troubleshooting/Problems 02-12-2013, 12:42 PM
Replies: 7
Views: 692
Posted By Triplecrown
Re: Sounds like an old floor board "Creaking"

True. I just had new sway links and bushings installed around a month or so ago. I would always hear a clunking noise over every bump. Now, my WK is so quiet and smooth when driving, it's better than...
Showing results 1 to 40 of 59

 
Forum Jump

All times are GMT -5. The time now is 04:27 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community