Go Back   Jeep Garage - Jeep Forum > Search Forums

Join Jeep Garage Today
Showing results 1 to 23 of 23
Search took 0.01 seconds.
Search: Posts Made By: Randomhero180
Forum: Troubleshooting/Problems 03-25-2013, 03:54 PM
Replies: 4
Views: 1,914
Posted By Randomhero180
Thanks. For the information. Sent from my...

Thanks. For the information.

Sent from my ADR6400L using Tapatalk 2
Forum: Troubleshooting/Problems 03-25-2013, 09:50 AM
Replies: 4
Views: 1,914
Posted By Randomhero180
Re: Weird water sloshing noise

It does sound like it is more inside, so I could be possible it is the air in the cooling system.

I'm really confused on why it is only for the first 30 seconds as well :confused:

I have...
Forum: Troubleshooting/Problems 03-25-2013, 07:47 AM
Replies: 4
Views: 1,914
Posted By Randomhero180
Weird water sloshing noise

This is very odd and just started happening after my last oil change.

After I start my Jeep first thing in the morning and during the first two turns out of my apartment complex there is a really...
Forum: Troubleshooting/Problems 01-24-2013, 08:54 AM
Replies: 16
Views: 1,333
Posted By Randomhero180
Re: Starting in cold weather

Tried this today after another cold night, didn't really do much to make it start better.

Also, just wanted to clarify the issue because I may have been confused on what I was saying was turning...
Forum: Troubleshooting/Problems 01-22-2013, 11:12 AM
Replies: 16
Views: 1,333
Posted By Randomhero180
Re: Starting in cold weather

Yes, just recently this summer had a lot of work done. New coil rail, spark plugs, fuel system cleaned out, and new computer installed. So I feel like if something else was wrong someone would have...
Forum: Troubleshooting/Problems 01-22-2013, 10:43 AM
Replies: 16
Views: 1,333
Posted By Randomhero180
Re: Starting in cold weather

I will try this after work today. Thanks for the tip.



I just put a little bit thicker oil then recommended because out how many miles my jeep is getting up to. Instead of 15w30 I used 15w40....
Forum: Troubleshooting/Problems 01-22-2013, 09:31 AM
Replies: 16
Views: 1,333
Posted By Randomhero180
Re: Starting in cold weather

I am not sure why I keep getting Autozone parts... Just had an issue with the oil sending unit too. I guess since I thought it was their premium battery I wouldn't have an issue. Guess I was wrong.
...
Forum: Audio/Visual/Navigation 01-22-2013, 08:49 AM
Replies: 1
Views: 499
Posted By Randomhero180
No FM radio

I still have my stock radio in my 99 Grand Cherokee. Randomly it stopped playing JUST FM radio. AM works and tape player works.

I tried a new antenna, no luck.

I am thinking the radio is just...
Forum: Troubleshooting/Problems 01-22-2013, 08:45 AM
Replies: 4
Views: 373
Posted By Randomhero180
Re: '99 GC Squealing

Finally got it fixed. Ended up just being a lose cable that was vibrating just right in between those speeds.

Really random....

But only cost me the price of a zip-tie to fix it, not too bad...
Forum: Troubleshooting/Problems 01-22-2013, 08:42 AM
Replies: 16
Views: 1,333
Posted By Randomhero180
Starting in cold weather

Well, it's a balmy 2F here in Michigan this morning!

With that, my 99 Grand Cherokee has been having some issues starting in this cold weather. I just installed a new battery about 2 weeks ago...
Forum: Troubleshooting/Problems 12-19-2012, 04:41 PM
Replies: 5
Views: 644
Posted By Randomhero180
I have 4.0l. I am hoping it is not...

I have 4.0l.

I am hoping it is not crankshaft bearing or oil pump.

My research lead me to a lot of people saying not to but the oil sending unit from a place like autozone because they rarely...
Forum: Troubleshooting/Problems 12-19-2012, 01:56 PM
Replies: 5
Views: 644
Posted By Randomhero180
The low oil light pressure light is not on in the...

The low oil light pressure light is not on in the picture . Unless I am missing something...

Yes the values are normal once I accelerate.

I replaced the oil sending unit because the oil...
Forum: Troubleshooting/Problems 12-18-2012, 06:45 PM
Replies: 5
Views: 644
Posted By Randomhero180
Oil sending unit.

Just replaced my oil sending unit now at idle my oil pressure is very low.

Is this normal?

Sent from my ADR6400L using Tapatalk 2
Forum: Troubleshooting/Problems 12-07-2012, 11:16 AM
Replies: 4
Views: 373
Posted By Randomhero180
Re: '99 GC Squealing

it is embedded in the post. you don't have to open it. Just hitting play should do it.
Forum: Troubleshooting/Problems 12-01-2012, 10:12 PM
Replies: 4
Views: 373
Posted By Randomhero180
No one has any ideas? Sent from my ADR6400L...

No one has any ideas?

Sent from my ADR6400L using Tapatalk 2
Forum: Troubleshooting/Problems 11-27-2012, 06:01 PM
Replies: 4
Views: 373
Posted By Randomhero180
'99 GC Squealing

When I am driving and I am between 55mph and 65mph there is a strange squealing when my foot is on the gas. When I let off or give it enough gas to jump gear it isn't there. Only when I use enough...
Forum: Troubleshooting/Problems 09-15-2012, 01:01 AM
Replies: 8
Views: 1,404
Posted By Randomhero180
It was the jeep dealer. Not sure of a better...

It was the jeep dealer. Not sure of a better place to take it! Haha

Sent from my ADR6400L using Tapatalk 2
Forum: Troubleshooting/Problems 09-14-2012, 03:17 PM
Replies: 8
Views: 1,404
Posted By Randomhero180
Took it in. Left rear wheel lug nuts were...

Took it in. Left rear wheel lug nuts were loose.... That is the last thing I would have checked.

Sent from my ADR6400L using Tapatalk 2
Forum: Troubleshooting/Problems 09-10-2012, 01:51 PM
Replies: 8
Views: 1,404
Posted By Randomhero180
I will take a look after work. Nothing on turns...

I will take a look after work. Nothing on turns and just had a bunch of suspension done, hoping they would have noticed that.

Sent from my ADR6400L using Tapatalk
Forum: Troubleshooting/Problems 09-10-2012, 01:01 PM
Replies: 8
Views: 1,404
Posted By Randomhero180
I6 4.0 Doesn't sound like it's coming from...

I6 4.0

Doesn't sound like it's coming from the engine though, could be wrong since all of my recent issues have been engine related.

Sent from my ADR6400L using Tapatalk 2
Forum: Troubleshooting/Problems 09-08-2012, 12:27 PM
Replies: 8
Views: 1,404
Posted By Randomhero180
Knocking while coasting.

I have a 1999 wj.

Just started noticing this last night.

When I am driving and take my foot off the gas to coast there is a knocking. Almost rotational noise, thought I was a flat at first,...
Forum: Tech Tips/DIY/How to 08-03-2012, 01:44 PM
Replies: 1
Views: 591
Posted By Randomhero180
Loose shifter button.

Need to get the shifter button to stop falling off. Any diagrams on how it clips on? Or do I need a new one?

Sent from my ADR6400L using Tapatalk 2
Forum: Troubleshooting/Problems 06-02-2012, 11:24 AM
Replies: 1
Views: 423
Posted By Randomhero180
Air Conditioning Issue.

Hi all,

I need a little help with my 99 i6.

My air cools fine but it cuts in and out. It will run for two minutes and then stops coming out for about 2 minutes, I can still hear it blowing,...
Showing results 1 to 23 of 23

 
Forum Jump

All times are GMT -5. The time now is 03:18 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.