Go Back   Jeep Garage - Jeep Forum > Search Forums

Join Jeep Garage Today
Showing results 1 to 4 of 4
Search took 0.01 seconds.
Search: Posts Made By: MWR1
Forum: Troubleshooting/Problems 03-23-2013, 03:31 PM
Replies: 6
Views: 831
Posted By MWR1
Re: Cranks and cranks and cranks then starts

The engine started normally with the sensor unplugged. Set an error code because there was no sensor feedback. Although the sensor was damaged, there were no parts of it released into the cooling...
Forum: Troubleshooting/Problems 03-23-2013, 11:04 AM
Replies: 6
Views: 831
Posted By MWR1
Re: Cranks and cranks and cranks then starts

And the winner is, drumroll please, COOLANT TEMPERATURE SENSOR!!!

The indication from the temperature gauge (180 degrees before turning the engine over when cold) was my best clue. As Frango100...
Forum: Troubleshooting/Problems 03-22-2013, 07:10 AM
Replies: 6
Views: 831
Posted By MWR1
Re: Cranks and cranks and cranks then starts

I've already changed fuel filter, fuel pump, and CPS. Still no resolution to the problem and I'm into it for about $400. I should have just gone to the dealership at this point, probably. I probably...
Forum: Troubleshooting/Problems 03-21-2013, 10:25 AM
Replies: 6
Views: 831
Posted By MWR1
Cranks and cranks and cranks then starts

Here’s the problem with my ’04 Grand Cherokee SE 4.0L: About a month or so ago it started getting difficult to start. Instead of firing immediately, it would turn over half a dozen or more cranks...
Showing results 1 to 4 of 4

 
Forum Jump

All times are GMT -5. The time now is 09:15 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community