Go Back   Jeep Garage - Jeep Forum > Search Forums

Join Jeep Garage Today
Showing results 1 to 6 of 6
Search took 0.01 seconds.
Search: Posts Made By: CAJeep
Forum: Troubleshooting/Problems 07-22-2013, 08:41 PM
Replies: 10
Views: 1,142
Posted By CAJeep
Re: Low vent air pressure

You'd laugh if you saw the "wiring harness" and how simple the fix is, and thus how idiotic the "manufacturing defect" is. It's basically two wires, one green and I think one white, both with male...
Forum: Troubleshooting/Problems 07-17-2013, 02:21 PM
Replies: 6
Views: 1,726
Posted By CAJeep
Re: Keeps losing oil, but no leaks...where's the oil gone..?

Good thought on the coolant check. I forgot to mention, I also thought it might be leaking into the coolant, but the color is bright green, no brown-ish tint whatsoever, so I ruled out a leak into...
Forum: Troubleshooting/Problems 07-17-2013, 12:39 PM
Replies: 6
Views: 1,726
Posted By CAJeep
Keeps losing oil, but no leaks...where's the oil gone..?

I have a '02 GC Overland (149K miles) and seems to run OK, but for some reason, keeps going through oil like it's gas...

I noticed it was below the ADD marker on the dipstick about a month ago, so...
Forum: Troubleshooting/Problems 07-17-2013, 12:30 PM
Replies: 3
Views: 1,067
Posted By CAJeep
Hissing noise - power steering or alternator??

I have a '02 GC Overland (149K miles), had a leak int he high pressure hose for the power steering pump, so I took it in to Firestone to have it replaced. They said the power steering pump was also...
Forum: Troubleshooting/Problems 07-17-2013, 10:01 AM
Replies: 10
Views: 1,142
Posted By CAJeep
Re: Low vent air pressure

Hey Frank.

Thanks for the quick replay and advice. I believe you are correct. After more research on-line late last night, I re-wired/reversed the 2 wires connecting the motor resistor and the...
Forum: Troubleshooting/Problems 07-16-2013, 11:51 PM
Replies: 10
Views: 1,142
Posted By CAJeep
Re: Low vent air pressure

I have a '02 GC Overland and the blower stopped working so I took it to a local shop to have it fixed. They said it was the blower motor resistor and thus replaced it. The fan does now turn on, but...
Showing results 1 to 6 of 6

 
Forum Jump

All times are GMT -5. The time now is 05:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.