Jeep Garage  - Jeep Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 · (Edited)
Hey guys,

Long time lurker here, finally decided to post.

I have an 05 GC Laredo with the 3.7L V6, 80,000 miles. Lately I've had some crazy issues with it. Last night my low oil pressure light came on while driving home from work. Realizing how serious that could be I pulled over, turned it off, and checked it out. I decided to limp it the last couple miles home, thinking I had a serious issue. I let the car cool down overnight and checked the oil in the morning, seeing it was right in the "safe" zone. I'd just done an oil change the week before. Today while driving to work my radio started to climb all by itself and out of nowhere from volume level 15 to 28 before I could turn the knob down. Had I left it alone the volume would've kept climbing. The audio equipment is aftermarket, including the receiver. While coming home tonight my dash went from bright to dull and back to bright. I was driving with the headlights on and they never flashed.

Sometimes the headlights come on when the unlock button is hit on the key, other times it doesn't. Also, the doors don't always unlock when the button is hit, sometimes I have to do it manually, not a big deal but could be related I suppose.

The battery in the car was replaced over the summer and the battery in the key was replaced this fall. The audio equipment was installed long before the problems started.

Any ideas what's going on? I'm just worried that ill come out of work one night to a smoldering pile of jeep.

Thanks fellas
 

·
Registered
2014 Jeep Summit
Joined
·
987 Posts
First off welcome, I'm thinking alternator is a possibility as well as battery even though its new oil pressure light is most likely the oil pressure sensor switch, any codes?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Thanks for the welcome and input. No codes, no corrosion on battery either. I haven't had the alternator checked yet.
 
1 - 3 of 3 Posts
Top