Jeep Garage  - Jeep Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
My jeep starts trying to die if it idles for about 15 minutes the only I have gotten is for a evaporative emissions leak and and one for a fuel mixture I replaced fuel tank fuel pump and the thermostat any suggestions
 

·
The beast from Brazil
Joined
·
8,310 Posts
Will it also die when driving, or only when idling? Could you give the exact codes you where getting? Did you change the fuel pump for this problem, or was something else going on? Low fuel pressure can be caused by a faulty/clogged fuel filter/pressure regulator, but fuel pressure related problems will normally give problems during acceleration and higher rpm´s.
A faulty O2 sensor could make the fuel/air ratio too low and the engine will simply die. That could explain that it will run ok for the first 15 minutes (still in open loop mode and not using the O2 sensor(s) for fuel fine tuning) and gets the problem when it has warmed up (now in closed loop mode and using the O2 sensor input for fuel fine tuning).
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #3 ·
It hasn't thrown any codes since I changed all of this but it only starts acting up at an idle it was doin it while driving but I changed the spark plugs and that cleared up. Now it's just when it idles. I've changed the fuel pump twice the first time the o ring broke and started dumping fuel the second time it started acting like it was sucking air at about a 1/4 of a tank and found a lot of trash in the tank and found that all inserts in the tank were busted so I got a new tank. Then it threw the fuel mixture code I researched and everybody kept saying to change the thermostat. Cuz if it didn't run hot enough it would mess with the air fuel mixture. Good thing because the thermostat was about to come apart.
 

·
The beast from Brazil
Joined
·
8,310 Posts
So did you change the fuel filter/pressure regulator already? Also a vacuum leak has influence on the idle speed. With the engine cold, the evaporative purge solenoid doesn´t work, but it will after warming up. So when there is a leak in the evaporative system, it could influence the idle when warmed up.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #5 ·
No I haven't changed that yet but like you said fuel pressure problem would cause problems more than just when it's idling. It doesn't really have any hesitation in throttle.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #6 ·
No I haven't changed that yet but like you said fuel pressure problem would cause problems more than just when it's idling. It doesn't really have any hesitation in throttle.
And it doesn't just die it just all of sudden starts acting like its running out of fuel
 

·
The beast from Brazil
Joined
·
8,310 Posts
If there was a lot of debris in the tank, i would change the fuel filter/regulator.
Did you check the evap lines? They tend to give problems on the rubber parts close to the rear axle. They dry out and break.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #8 ·
I changed the filter it's part of the fuel pump I changed it when I changed the tank. Where is the regulator located.
 

·
The beast from Brazil
Joined
·
8,310 Posts
The one at the pump is just an inlet screen, not really a filter. You will find the filter/regulator just in front of the rear axle on the left side. There is a writeup in the DIY section of the WJ regarding the filter/regulator change.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #10 ·
I changed the filter/ pressure regulator didn't help but I noticed after I changed it when I had my hands on the fuel lines you can feel the fuel passing through it then it would stop for a little bit then go back to flowing like the fuel pump keeps going off and on
 

·
Registered
Joined
·
76 Posts
Could this be your Idle Air Control valve? You might try unbolting your throttle body and IAC and soaking them in kerosene and taking a toothbrush to them to get them squeeky clean again... Even if this isnt the culprit, its a good practice anyways once and a while on the 4.0s.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #12 ·
I guess it could be cuz it doesn't idle back down real quick. If rev it about 2000 rpm and let off it holds there for about a second then it slowly falls
 

·
Registered
Joined
·
76 Posts
Well im definately no expert, but my wrangler was having trouble holding idle, and this was the cure. I hope this helps.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #16 ·
The jeep has went back to acting up in idle it has thrown the codes p0455 and p0442 which is a small leak and a large evap leak
 

·
The beast from Brazil
Joined
·
8,310 Posts
Did you check the vacuum lines going to the evap canister behind the left rear wheel? These lines pass around the rear axle, where the rubber hose dries out and breaks.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #18 ·
When I changed the fuel filter and it kept dying when it was idling. If you held the fuel lines there it felt like the fuel kept shutting off and coming back on and you can kinda hear a sucking sound right around where your talking about
 

·
The beast from Brazil
Joined
·
8,310 Posts
If you want to know if a leak in the evap line is causing the problem, you could easily plug the line under the hood. The purge solenoid is mounted on the left fender (seen from drivers position) and you could follow the lines to see which one is going to the engine inlet duct. You could plug that one temporarely to test. But you have some vacuum leak for sure if you hear a hissing noise at the rear, so you better just try to solve that and be done.
Never touched the fuel lines, but as far as i know will the fuel pump run constantly when the engine runs and will the fuel pressure regulator in the filter assy regulate the fuel pressure to around 45 PSI (when im not wrong about the figure) and will the surplus fuel be send via the return line back to the tank.
 
1 - 19 of 19 Posts
Top