Jeep Garage  - Jeep Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
i have a 2005 grand Cherokee jeep with a 4.7 v8 and 116k miles on it. bought it up in Alaska, currently live in south Dakota, and it hasn't seen any "hot" weather 75+ since Ive owned it...but 4 days ago, i drove down here to Oklahoma city, and on the way down i noticed on and off when i came to a stop it started shaking...then randomly stopped again. this has been going on all week now, but today(78F+), when i start it up, it runs smooth, then after a 5 to 10 seconds, it slowly goes into a shake. when it shakes it feels like a small 4 cylinder diesel.
I just changed all the spark plugs, didnt make a difference. And another thing, when it shakes, i can unplug each coil and on every one you do notice the RPM change and the shaking doesn't stop, so i dont think its a dead cylinder/plug/coil/injector. and even it would be a dead cylinder...it shakes a LOT worse then it would if I just had a coil misfiring.

any ideas?
 

·
Registered
2014 Jeep Summit
Joined
·
987 Posts
Mine has done this for awhile, egr valve mostly cured my problems along with a tps sensor, does the idle go up when ac is turned on?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
The idle was rock solid at 600rpm...
it was the electric AC condenser fan, it was caked full of mud which threw it off balance, took it to the car wash, took a water hose to it, cleaned it off, and no more vibrating...
 

·
Let's Roll
Grand Cherokee
Joined
·
13,095 Posts
The idle was rock solid at 600rpm...
it was the electric AC condenser fan, it was caked full of mud which threw it off balance, took it to the car wash, took a water hose to it, cleaned it off, and no more vibrating...

that happened to me last year, it was driving me nuts trying to figure it out!
 

·
Registered
Joined
·
171 Posts
I used to run K&N air filters and a couple of times installed the filter with to much oil and it gummed up the throttle body and caused a rough idle cleaned all sensors and throttle body and it was fine.started to use shop vac with a rag after that to make sure no extra oil was on the filter.
 
1 - 5 of 5 Posts
Top