Jeep Garage  - Jeep Forum banner

21 - 28 of 28 Posts

·
Registered
Joined
·
62 Posts
Does anyone know why my fog lights are not working now I just noticed now is it because the new TIPM installed? They worked fine before


Sent from my iPhone using JeepGarage
 

·
Registered
Joined
·
42 Posts
Installed my rebuilt TIPM from ARspeedometer ($269) works great I highly recommend going that route if you have no warranty and your TIPM is the issue.
 

·
Registered
Joined
·
29 Posts
Took it to the dealer and they said It was an issue with the fuel pump. They installed a fuel pump relay total was $283. Glad it wasn't the TIPM issue which looks to be over a grand but still bummed that I had to come out of pocket when my car is only about 2 years old. Relieved to have it fixed though, it was a major pain in the ass.
If they installed a fuel pump relay it probably was a bad TIPM. That's the cheap way of fixing the TIPM problem.
 

·
Registered
Joined
·
1 Posts
I got similar problem with my 2012. I hit the start button and it just started cranking, but would not start. After about 20 min it finally started. Later on that day the same thing happen again. It started but was afraid to drive it. I had a tow truck take it to the Jeep dealer. Dealer kept it 2 days, but could not find any problems- no codes, battery ok. I drove it home. I am concerned what is my next step ? Any suggestion .
 

·
Registered
Joined
·
29 Posts
I got similar problem with my 2012. I hit the start button and it just started cranking, but would not start. After about 20 min it finally started. Later on that day the same thing happen again. It started but was afraid to drive it. I had a tow truck take it to the Jeep dealer. Dealer kept it 2 days, but could not find any problems- no codes, battery ok. I drove it home. I am concerned what is my next step ? Any suggestion .
Have you had the TIPM recall work done yet?
 

·
Registered
Joined
·
1 Posts
I been having this issue for the past week where my can't wont start with the control. Also it hasn't been starting when I go into the car and press the push start. It makes a weird sound but won't start. We eventually get it started but takes along time and it has become a big pain in the ass. Has anyone else experience this issue? I have read people having similar issue and it ended up being TIPM, I don't know what that is but I know it's around 1100 or 1500 to fix. That's bad for me because my jeep ain't under warranty. Any recalls out there for this?


Only u can prevent forest fires.
Do you have to step on brake pedal at the same time. I do on mine.
 
21 - 28 of 28 Posts
Top