Jeep Garage  - Jeep Forum banner

41 - 60 of 91 Posts

·
Premium Member
anything with wheels
Joined
·
1,852 Posts
Hmmm... they "can't" do the TSB since it doesn't show up for my VIN and want to spend 3 or 4 hours "training" the transmission.

WTF? :confused:
You can train the transmission yourself. Its just driving in a specific pattern. I have the document and have done it myself. You need to complain that your transmission shifts harshly under certain conditions. Keep complaining. Yes, it's rediculous. I know you have an early build like me...and I have the TSB update.
 

·
Premium Member
Joined
·
4,080 Posts
There is a thread about resetting and training your transmission, it was more for the 3.6 V6 Transmission though, but the same principle follows.
Unplug battery for 15mins, then drive it smoothly for a while. Something like that, I can;t find it, I did find it about a week or so ago in regards to battery disconnection and reset time.
 

·
Premium Member
Joined
·
1,159 Posts
Anyway to tell if the ECU was actually updated?
 

·
Registered
Joined
·
624 Posts
I had the TSB applied, and this is what I experience now: 1) up shifting: when increase speed gradually, the gear is one gear above the corresponding speed, e.g, 4th gear~30kph, 5th gear~40kph, 6th gear~47kph, 7th gear~60kph, 8th gear~70kph; 2) down shifting: the gear is around 2 gears higher than the corresponding speed, eg, gear drops from 8 to 7 when speed drops from 95kph to 60kph, then drop to gear 6 when speed drops further to 47kph.

Has anyone who had the same TSB applied experienced the same or similar?

Thanks
 

·
Registered
Joined
·
896 Posts
I had the TSB applied, and this is what I experience now: 1) up shifting: when increase speed gradually, the gear is one gear above the corresponding speed, e.g, 4th gear~30kph, 5th gear~40kph, 6th gear~47kph, 7th gear~60kph, 8th gear~70kph; 2) down shifting: the gear is around 2 gears higher than the corresponding speed, eg, gear drops from 8 to 7 when speed drops from 95kph to 60kph, then drop to gear 6 when speed drops further to 47kph.

Has anyone who had the same TSB applied experienced the same or similar?

Thanks
I dont get what you are trying to say/describe.
 

·
Premium Member
Joined
·
4,080 Posts
I do, and as for upshifting I would say that is how mine has been from day one. I have not had the TSB applied yet. Not sure about downshifts though.

What he is trying to say, is the the gear shifts into a gear corresponding to 1/10 of the velocity, plus 1. Gear = (v/10) + 1.
So
30kmh shifts into 4th
40kmh shifts into 5th
50kmh shifts into 6th
60kmh shifts into 7th
70kmh shifts into 8th
 

·
Registered
Joined
·
624 Posts
Before the upgrade, gear corresponded to speed, e.g, 4th gear~40kph regardless up shifting or down shifting, which was quite accurate. My concerns now, after the upgrade, are 1) down shifting: 2 gears higher than corresponding speed, and 2) hard acceleration which I didn't mention in the initial post. I did a few rounds of road test on M4 with only a TAD hard acceleration which one would normally do when overtaking. The experiences are quite different: 1) up shifting in gear is slower than increase in corresponding speed, 2) gear changed to 7th after speed reached 75kph, and didn't increase to 8th until speed reached 95kph, and I could feel that engine/rev "over labored" before gear increased to 8th. I tested a few times, and yielded the same result every single time.

It appears that symptoms I experience now are what TSB intends to fix. Buggar!
 

·
Registered
Joined
·
2 Posts
I have these exact problems now only when cold. 2014 GC with 11k miles. Has been doing this crap for 2 months. No luck so far. At the shop tonight so they can drive cold tomorrow.
Will advise.
 

·
Premium Member
Joined
·
1,159 Posts
Okay, so its been awhile since I had them "train" the transmission (I do not believe they applied the flash) and its actually been pretty good. The hard downshift from 2-1 which was the most pronounced issue is gone. I still get an occasional lurching shift when I go from hard acceleration and take my foot complete off the gas but thats rare.
 

·
Registered
Joined
·
83 Posts
V8 Hemi here....

Does anyone else feel like the coasting or downshifting is similar to a governor feeling in a golf cart? For the life of me, I can't figure out why a car would not coast smoothly.

I returned my V6 for a V8 in hopes this would improve. It has, but the shifting is still a pain.
 

·
Premium Member
anything with wheels
Joined
·
1,852 Posts
Okay, so its been awhile since I had them "train" the transmission (I do not believe they applied the flash) and its actually been pretty good. The hard downshift from 2-1 which was the most pronounced issue is gone. I still get an occasional lurching shift when I go from hard acceleration and take my foot complete off the gas but thats rare.
I'm in the same boat...I have 3500 miles since my last TCM reset and my shudder is very infrequent and no unusual thumps...but I've been driving long distances with a consistant style. I have a feeling if I drive more aggressively, the shudder would return. I think the adaptive algorithm gets confused.

The surge from letting off the accelerator right before a shift is unavoidable. The stored inertia in the motor has to go somewhere and the boost hasn't bled down so you get a little push. Its more apparent with our higher torque motors. I've played around with it since everyone is very sensitive to transmission behavior. Letting off the accelerator less abruptly seems to smooth it out.
 

·
Registered
Joined
·
158 Posts
Had my free 1000km check-up done yesterday and this TSB applied.

I do about 20km of driving in peak hour freeway traffic each day at 0-30km/h with a lot of stops. I noticed the 2>3>4 and 4<3<2 harsh shifts in ECO mode. The kick-down at very light throttle was very harsh at times. Turning ECO off made it a little better but still not great. Reported this to my service department and they carried out the update.

Initial impressions thus far are positive. First impressions are the car feels a lot more responsive, almost like the converter locks sooner. Feels a lot more responsive even with ECO mode on. The shifts at low speed and light throttle have been greatly improved.
 

·
Registered
Joined
·
210 Posts
Hello ,. I have similar problem on my 2014 laredo e .. I try 2 use the sport mode and the Eco keeps on .. And it jumps from 1 to 3 .. Took it to the dealer and they upgrade or reset it .. It works for a 3 days . Is still the same and then a notice the speedometer blinks
And my car has only 455 miles..


Sent from my iPhone using JeepGarage
 

·
Registered
Grand CherokeeLaredo
Joined
·
401 Posts
Had my free 1000km check-up done yesterday and this TSB applied.

.
What free 1000k check-up?

I just bought mine on the 26/11, I asked my salesman about the first service and he said they don't need it! Pointed to the service sticker on the windscreen that shows 10k :rolleyes:

Have I been shafted?

PS: just clocked 1250km now
 

·
Premium Member
Joined
·
4,080 Posts
Not really, the 1,000km check up is basically to make sure all 4 wheels are still there and fix any issues you have found already. I didn't bother with mine.
 
41 - 60 of 91 Posts
Top