Jeep Garage  - Jeep Forum banner

61 - 80 of 91 Posts

·
Registered
Joined
·
83 Posts
Has anyone heard anything new regarding the TSB & ECO Mode? How do you even know they applied the TSB other than the notes stating they did?


Sent from my iPhone using JeepGarage
 

·
Registered
Joined
·
83 Posts
That's my point. TSB applied yet ECO comes back on. Multiple people on this board have had the same experience after applying the TSB.

I'm curious if there is a way to confirm a TSB was actually applied.


Sent from my iPhone using JeepGarage
 

·
Registered
Joined
·
80 Posts
after 4 trips to the dealer.
originally 3-4 was rough shift. dealer re-flashed.
upon refleash 1-2 only when trans under 100 degreed F. hard shift. and 5-4 anytime slammed.
Took back. left for a week while on vacation.
" yeah last time the quick learn process wouldnt learn" (so they gave it back to me like that...????)
re-flashed agian, actually performed quick learn. tech drove it home for 4 days to verify.
1-2 was better but not fixed. again, only happened when trans temp below 100 degrees.

so.......................... took it back for them to replace my steeringwheel that they ripped the leather on while they had it, and to check then 1-2 shifts again.

a week later, they didnt replace the steeringwheel, because they thought i was talking about he stitching, thye did however REPLACE MY ENTRIRE TRANS, on at 700 miles after replacement, and its perfect.
cant feel any upshift or down shift, even when driving 45mph then floor it to pass someone.

dealer tells me "there was a sensor internally that they cant fix, so the replaced the entire trans.
had my jeep for 8 days.
 

·
Premium Member
Joined
·
233 Posts
Good result I would say.


Sent from my iPhone using JeepGarage
 

·
Registered
Limited White
Joined
·
9 Posts
I was there today 8-28-15 describing these exact issues, and they said nothing about these updates...have an appt thurs though so hope they get it together...
 

·
Registered
Joined
·
2 Posts
Hey all. I have the usual transmission issues. 2015 Overland V6. Has been reflashed, no go. New valve body, no go. It is now getting a new transmission. Hope it works better than the original. I will post results later.
 

·
Registered
Joined
·
51 Posts
All this said about the 8-speed auto is disappointing especially after being in service now for a few years. Is this transmission also as troublesome in the Cherokee with the 9-speed gearbox?
 

·
Registered
Joined
·
80 Posts
All this said about the 8-speed auto is disappointing especially after being in service now for a few years. Is this transmission also as troublesome in the Cherokee with the 9-speed gearbox?
Somewhat.

I had a 2014 cherokee before I traded it in for the Grand. 3.2L v6 with 9speed and 4wd MINOR shift issues compared to the grand. Biggest issue was the lack or response when downshifting.

NO JOKE, if I was doing 45pmh, and wanted to pass someone, Id floor it. took 2-4 seconds before the trans would drop from 7th or 8th to 4th ro 5th. Meaning, I had to time it perfectly ever time. Id put my foot down to pass, and change lanes at the same time, then be completely in the new lane at the old speed waiting for the "kick back" of the down shift to go. several times I almost got rear ended because I wasnt up to speed of that lane before I got in it. (which is hard to do sometimes, because youre creepin along behind someone doing 35 in a 45)
 

·
Registered
Joined
·
1,981 Posts
I have started a thread and bumped it several times with no responses. My 15 V6 GC makes a terrible noise shifting from 1-2 and 2-3 under hard acceleration. Is that normal? Service dept said it was :(

It also won't use 8th gear after 79mph. I can use the paddle shifters and shift into 8th and put it back in auto and it will stay there. It's VERY annoying since I'm frequently driving on a toll road of 85mph outside of San Antonio, TX. I had the service dept check to see if there is an update for it but they said no. It was built 6/15 so it's pretty new.
 

·
Registered
Joined
·
83 Posts
Bump.

Just had a new valve body put in and although it seems to shift better when accelerating, it is still GOD AWFUL when coasting/braking.

It feels like there is a governor that won't let it coast freely, or like I'm pulling something. Then, once it downshifts, it costs freely until repeating itself when the speed reduces further.

Are there any other options to improve the drive quality? 2nd JGC (first one they bought back), now this one has multiple services , TSBs, valve body, etc.


Sent from my iPhone using JeepGarage
 

·
Registered
Joined
·
15 Posts
I bought my jeep gc in october, i have about 7500 miles on it now, but all of a sudden i noticed that from going to gear 2 to 3 it lags, seems like im driving a manual car. Anyone recently having the same problem lately? it is really annoying and i know something is up with it. took it to jeep and they said there was no update for it. I think its a tranny issue but we will see
 

·
Registered
Joined
·
80 Posts
Had the EXACT same issue. Around 7612miles, my dealer replaced my entire trans. Currently @ 12k ish and problem is starting again. Try this. put your display into trans temp mode, and see if you can narrow down the problem. My would only have rough shifting when the trans temp was under 110 degrees F. After that smooth in any combo of gears (1-2 2-3 5-6 7-6 etc)
Its mo surprise a chrysler has a trans issue, but this is a dialmer/benz design, now owned by the same company that owns Hostess....
 

·
Premium Member
Joined
·
4,080 Posts
Its mo surprise a chrysler has a trans issue, but this is a dialmer/benz design, now owned by the same company that owns Hostess....
No on both accounts. The Benz connection is the chassis, nothing to do with the trans, in fact the 8HP that our 8HP70 stems from was first used by BMW, as was their first 6SP that I have in my Ford.

As for ownership, wrong on a couple of fronts, ZF is not owned by anyone, it acquires other companies. No one really owns Hostess, it was broken up and sold all over the place.
 

·
Registered
Joined
·
83 Posts
So I take it no one has found an actual resolution other than repeated trips to the dealer and winning the lottery via a TSB (I lost, as my TSB didn't help)?


Sent from my iPhone using JeepGarage
 

·
Registered
Joined
·
111 Posts
I would like to know this as well. Taking mine to the dealer on Aug 12th and doing a ride along just so I know they can feel it.

It falls on its face after accelerating at a low speed and letting go of the gas.

Shifting 3-2, it feels like I am letting the clutch out too fast when driving a manual car. It just skips and shudders.

No way a tranny should feel like this. Fix my tranny and this would be the best vehicle ever!


So I take it no one has found an actual resolution other than repeated trips to the dealer and winning the lottery via a TSB (I lost, as my TSB didn't help)?


Sent from my iPhone using JeepGarage
 

·
Registered
Joined
·
111 Posts
Took a mechanic from the dealership for a ride on Friday. He said they could feel it and to bring it back on Monday because they were back logged on the weekend and wouldn't get to it until Monday.

Drop it off Monday. Called both today and yesterday and they haven't even gotten to it. Wish I could drop it off when they could ACTUALLY do it and not take an uber to and from work every day....

Regardless, hope they have a solution to the problem otherwise I am going to get rid of it for something else because I highly doubt it's supposed to hiccup between gears like this (and I keep getting a run around that it's the torque). Never had problems like this with any other vehicle manufacturer.
 
61 - 80 of 91 Posts
Top