Jeep Garage  - Jeep Forum banner
1 - 20 of 31 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Maybe someone can shed some light on this for me... Got in the car yesterday, turned it on, and every warning light, alarm, bell, and whistle came on. Turned it off, let it sit for a few minutes, then tried again. While the circus on my dash had finally calmed down, the "check engine" light was still illuminated. Brought the car up to the dealership to have service take a look at it. They informed me that the car needed "a new electronic shift module". Mind you, the car is only 5 weeks old. Here's the problem... They told me that the part is back-ordered... Won't be able to get one in for at least 2.5 weeks. Needless to say, this is less than satisfactory for a new purchase. I asked them to pop one out of another new truck on the lot and swap it into mine, to which they responded, "We can't. They're all different". I find this pretty hard to believe. I mean, Jeep doesn't manufacture unique shift modules for every single car that comes off the line, right? There shouldn't be an issue swapping a new one for my defective one, should there? HELP!!!!!!
 

·
Registered
Joined
·
29 Posts
The SAME exact thing happened to me last Friday. After turning the car off and back on (after all the warning lights were yelling at me), the only warning light to remain on was the Check Engine light. I took it to my dealer the next morning, but they didn't have time to look at it, so I made an appt for Monday morning (5/13). Sometime over the weekend though the Check Engine light went off. I called the dealer Monday morning to ask if they still wanted me to come in, since things were back to normal, and they told me no...
If it happens again to bring it in.

No warning lights have come on this week. Hopefully it was a 1 time thing.

And this happened less than 2 weeks since purchase!
 

·
Premium Member
2017 Summit
Joined
·
8,888 Posts
I have what seems to be the same problem. My dealer, after discussing it with someone at Chrysler said it was the PCM. Last Friday they said it would be in a couple of days.

Either Chrysler didn't plan well, not having replacement parts in the supply chain, or they already used up all they had. Neither situation leaves you feeling good about Chrysler.


---
 

·
Premium Member
2017 Summit
Joined
·
8,888 Posts
The SAME exact thing happened to me last Friday. After turning the car off and back on (after all the warning lights were yelling at me), the only warning light to remain on was the Check Engine light. I took it to my dealer the next morning, but they didn't have time to look at it, so I made an appt for Monday morning (5/13). Sometime over the weekend though the Check Engine light went off. I called the dealer Monday morning to ask if they still wanted me to come in, since things were back to normal, and they told me no...
If it happens again to bring it in.

No warning lights have come on this week. Hopefully it was a 1 time thing.

And this happened less than 2 weeks since purchase!
The fact that the check engine light came on, even though it went off, the dealer should have had you come in so they could see what codes were stored, and get it reported. The last time it happened to me, the computer spit out two pages of codes.


---
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Agreed... Can't say this leaves the best taste in my mouth. PCM or shift module, why can't a properly functioning one be pulled from another vehicle and swapped? Don't get me wrong, the most time I've spent under a car was looking for something my wife dropped, so I'm less than the consummate mechanic. But my mediocre mind tells me that it shouldn't be all too complicated to swap the two... Could it be that the dealer doesn't want to take another vehicle of the selling block?
 

·
Registered
Joined
·
1 Posts
The same thing happen to me at exactly 150 miles in two different 2014 GC. The dealership gave me a brand new loaner limited 4X4 and at 150 miles I had the exact same thing. Two hours later and I was left with just the check engine light. I called the dealership and they said to bring it in the next day because mine was due to arrive in the morning. When I started it up to head to the dealership everything was normal. After taking delivery of my new GC at 150 miles the same thing happened. However, several hours later when I went back to start it up everything was back to normal and has been for the last 1500 miles.
 

·
Registered
Joined
·
391 Posts
Yikes! you guys are making me nervous. I just got mine Tuesday and it's got 300 mi on the clock. So far so good. Will you please continue to post updates and soloutions.
Thanks
 

·
Registered
Joined
·
783 Posts
Yikes! you guys are making me nervous. I just got mine Tuesday and it's got 300 mi on the clock. So far so good. Will you please continue to post updates and soloutions.
Thanks
If it makes you feel better, I just hit 3000 miles with none of these issues.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #10 ·
As far as I can tell, the ESM is NOT VIN specific/coded. That would be the only reason (aside from not wanting to) that the dealer can't swap it out from another truck. Does anyone know anything to the contrary?
 

·
Registered
Joined
·
391 Posts
It seems reasonable to have them find one somewhere, even in another new vehicle. If it gets to be a stalemate, I would go over the dealer to a regional center/manager and keep going up the food chain, being polite but unyielding in your need to be made whole on such a large purchase. Dealers seem to worry about themselves, while the higher ups are more concerned with brand reputation and have more options to help.
 

·
The Negotiator
Joined
·
5,364 Posts
thanks Specx, that does make me feel a little better
I have over 1200 miles with no problems. You have to remember as it has been stated in almost every thread that you see a lot of complaints about same issues with those that don't really have issues are enjoying them.
 

·
Premium Member
2017 Summit
Joined
·
8,888 Posts
I have over 1200 miles with no problems. You have to remember as it has been stated in almost every thread that you see a lot of complaints about same issues with those that don't really have issues are enjoying them.
Even with complaints some of us are still enjoying the ride. The fishing gear is loaded for a trip to the ocean tomorrow morning. But that nagging feeling the something else might go wrong is always there.

It seems that different dealers are considering different approaches to fixing the same problem. To me that means that Chrysler has not come up with the right answer and our Jeeps are the test dummies.



---
 

·
Premium Member
Joined
·
4,989 Posts
Even with complaints some of us are still enjoying the ride. The fishing gear is loaded for a trip to the ocean tomorrow morning. But that nagging feeling the something else might go wrong is always there.

It seems that different dealers are considering different approaches to fixing the same problem. To me that means that Chrysler has not come up with the right answer and our Jeeps are the test dummies.

---
Bill, go have fun.

As noted in another pst I made. I don't agree that customers be beta testers but it seems to be the trend these days. I am not just talking cars....
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #17 ·
More than happy to post codes if/when the dealer gets back to me... SMH... Can't say I'll be rushing back to get service done at the dealership anytime soon.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #18 ·
update... after nearly a week, there is very little to add. Have spoken to the parts department at the dealership, and they, too, informed me that the ESM is VIN coded. As of today, they still have no time frame as to when the part will be available. Suggested that I speak with my salesperson. If only it were that easy. I have left 3 messages since last thursday, none of which have been returned. The guy in the parts department (who thus far has been the most helpful person I have spoken with) said I should contact Jeep customer care to check on the status of my claim. The Jeep representative indicated that the claim was sent to the expedited parts department last week, however, there has been no response yet. Apparently NO ONE has any idea of when these parts will be available. The customer rep then told me that if I don't hear back from a representative in the next two weeks, "...you should probably call to check on the status again." Love the truck, strongly dislike being without it, but can't stand the complete and total lack of information regarding its availability...
 

·
Premium Member
2017 Summit
Joined
·
8,888 Posts
update... after nearly a week, there is very little to add. Have spoken to the parts department at the dealership, and they, too, informed me that the ESM is VIN coded. As of today, they still have no time frame as to when the part will be available. Suggested that I speak with my salesperson. If only it were that easy. I have left 3 messages since last thursday, none of which have been returned. The guy in the parts department (who thus far has been the most helpful person I have spoken with) said I should contact Jeep customer care to check on the status of my claim. The Jeep representative indicated that the claim was sent to the expedited parts department last week, however, there has been no response yet. Apparently NO ONE has any idea of when these parts will be available. The customer rep then told me that if I don't hear back from a representative in the next two weeks, "...you should probably call to check on the status again." Love the truck, strongly dislike being without it, but can't stand the complete and total lack of information regarding its availability...
Your first post said that they told you it would be at least two and a half weeks. It's been five days. I know you are anxious, but what made you think they would have something new to tell you?
 

·
Registered
Joined
·
1 Posts
Hi everyone,

We bought my 2014 JGC in March and are having the same issue. Took it in to the dealership today and they told us it was the shift module and it's backordered. They told us it was safe to drive, but I'm leary. Are you all driving your Jeeps until the part is delivered or did your dealership give you a loaner?

Thanks
 
1 - 20 of 31 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top