Jeep Garage  - Jeep Forum banner
1 - 14 of 14 Posts

·
Registered
gc limited luxll
Joined
·
523 Posts
Discussion Starter · #1 ·
hey everyone,i just wanna say thanks for all the info on the install directions,wow what a pia lol,i also installed the overland mesh grille while I had the bumper off,so my problem is the driver side look like a spot light going down the road,passenger side cutoff line is straight n smooth,but the drivers side cutoff is in the shape of the letter u and a noticeable beam of light instead of a flood,think I have the bulb in wrong?but its so hard to to remove it becasuse I drilled a 1"hole in the plastic cup for the grommet and snaked all the wires through it,just no wiggle room
 

·
Registered
gc limited luxll
Joined
·
523 Posts
Discussion Starter · #3 ·
thanks fryingpan,i guess ill have to go through the hassle of ripping it apart,ughhh,such a pia taking the plastic boot off with the 1" hole drilled in it,no wiggle room with new wires,dont wanna have to take bumper off again
 

·
Registered
Joined
·
93 Posts
Yea, its a bit of a PITA. I ended up disconnecting the harness from the ballast and relay and backing the cap off of the grommet, re-attaching everything, checking the alignment, attaching the cap, THEN refitting the grommet by pulling it through from the inside of the cap.
 

·
Registered
gc limited luxll
Joined
·
523 Posts
Discussion Starter · #5 ·
Yea, its a bit of a PITA. I ended up disconnecting the harness from the ballast and relay and backing the cap off of the grommet, re-attaching everything, checking the alignment, attaching the cap, THEN refitting the grommet by pulling it through from the inside of the cap.
ok well I removed the bulb and reinstalled it making sure it was nice n straight,just took a drive tonight and its still bad,terrible cutoff and its like a flashlight beam of light shining toward the right with very little light on the left side of the bulb,wtf im confused,i just pm'ed xd to see what they have to say,i know its in properly
 

·
Premium Member
2018 Jeep Trackhawk
Joined
·
57,003 Posts
lets see some pics
 

·
Registered
gc limited luxll
Joined
·
523 Posts
Discussion Starter · #7 ·
ok one is the passengerside with proper flood of light and cutoff,the other is drivers side with bad cutoff and ball of light I guess you would say,last is the beam,hard to tell from pic but its like a beam instead of a even flood,i can take better ones if needed,i blocked each light separately so you could see the difference,the road shot is nothing in comparison of how bad it is
 

Attachments

·
Premium Member
2018 Jeep Trackhawk
Joined
·
57,003 Posts
I dont think you have the bulb in correct or your broken the bulb
 

·
Registered
gc limited luxll
Joined
·
523 Posts
Discussion Starter · #9 ·
ok good,i least im not losing my mind,i doubled checked the bulb and its in straight,i was gentle installing,possibly a defect I guess
 

·
Registered
Joined
·
152 Posts
I have the exact same issue with mine. I have a replacement bulb so I'm gonna get it taken care of as soon as I can. Been busy all weekend. I'll give you updates when its all done.
 

·
Registered
gc limited luxll
Joined
·
523 Posts
Discussion Starter · #11 ·
I have the exact same issue with mine. I have a replacement bulb so I'm gonna get it taken care of as soon as I can. Been busy all weekend. I'll give you updates when its all done.
oh really,glad im not the only one,is it your drivers side also?does it look like a flashlight on the road?
does anyone else have this issue???
 

·
Registered
gc limited luxll
Joined
·
523 Posts
Discussion Starter · #12 ·
ok well I talked to steve from xenon depot and I did a dumb thing,im only telling one this so they don't do the same thing,on the h11 bulbs there are two gaskets on them,you need to remove the hard plastic white one then put the orange rubber back on,i didn't do this,didnt know I was supposed to,well steve is sending me a replacement anyway just because there might be damage,xd customer service is incredible,gonna take her back apart when I get the replacement,im sure this will fix any issues ill post pics when I reinstall them
 

·
Registered
Grand Cherokee
Joined
·
7 Posts
ok well I talked to steve from xenon depot and I did a dumb thing,im only telling one this so they don't do the same thing,on the h11 bulbs there are two gaskets on them,you need to remove the hard plastic white one then put the orange rubber back on,i didn't do this,didnt know I was supposed to,well steve is sending me a replacement anyway just because there might be damage,xd customer service is incredible,gonna take her back apart when I get the replacement,im sure this will fix any issues ill post pics when I reinstall them
I have exactly same issue, problem with driver side. Would appreciate for sharing how to resolve this issue.
 

·
Registered
Altitude
Joined
·
2,773 Posts
You should have tested them out before putting the front end back together :whistle:

I couldn't believe what a PITA it was just to do an HID install. I too did the overland mesh inserts since the bumper had to be pulled.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top