Jeep Garage  - Jeep Forum banner
1 - 9 of 9 Posts

· Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I have a 2014 Grand Cherokee Limited with the 8.4A radio.

Recently my compass disappeared from both the radio display and the speedo display. Does anyone have any ideas what to check? Would much rather find a simple solution than have to go in for warranty for this.

Thanks in advance.
 

· Premium Member
Joined
·
3,476 Posts
Did you check your settings in the EVIC and Uconnect? First place I would look.
 

· Registered
Joined
·
779 Posts
On the cluster, you have to go through the settings with the steering wheel and should be able to set which corner you want the compass to display on. I'm not sure on the radio, but there should be an option there. I think mine was always set, but I would think it's under the display menu.
 

· Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
On the cluster, you have to go through the settings with the steering wheel and should be able to set which corner you want the compass to display on. I'm not sure on the radio, but there should be an option there. I think mine was always set, but I would think it's under the display menu.
Definitely aware of all these. The issue is no matter what position I tell the compass to appear in (Top left, Top Right) it is blank.

On the 8.4 screen there are two dashes ( -- ) where I swear it used to show up as well.

It's almost like the compass stopped reporting data.
 

· Premium Member
Joined
·
3,476 Posts
There's a section in the OM about compass calibration. If that doesn't help, then I guess you'll need a trip to the dealer.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top