Jeep Garage  - Jeep Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
Posting this to (hopefully) help someone who has a similar problem.

My partner has a 2017.5 (new version) Compass that she bought new in late 2017. It's got about 40,000 miles on it.

We got in it 1 evening to go pick up a pizza and it wouldn't start. I took the battery out the next morning and took it to a local battery place. They tested it and it was good, but discharged. Charged it up and the car started fine. She wanted a new battery, so I went back and got a new one. It's started fine ever since. Still don't know what discharged it, but it hasn't happened again.

BUT

About 75% of the time UConnect would not have any sound at startup. All of the buttons worked, but no sound. Tried resetting it and disconnecting the negative battery terminal. It would play but usually just on the first start. I was getting ready to pull the head unit and exercise connections when it dawned on me that it probably has an AUX battery. Took that out and the battery store didn't have any, so I got 1 from the dealer. It has not had the no sound issue since.

When I replaced the main battery I never even considered it would have an AUX battery. Weird symptom, but worth the $140 to get it cured.
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top