Jeep Garage  - Jeep Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi all! I’m a first time Jeep owner, 2020 Renegade w/ 7200 mi. I started having an issue with my locks a couple of weeks ago.
They lock normally if I go to get something out of it and lock the doors again, but malfunction after driving normal short trips (haven’t been on a longer trip to comment.) I park for the night and set the alarm with the fob. The lights flash, horn sounds, but don’t hear the doors lock. Sure enough, the doors are unlocked when I try to open them. I’ve even left my key in my house to try this so there’s no interference from the passive entry on the fob. I try with the button on the inside door panel, those don’t work either. I end up manually having to flip each door switch manually to lock them. The dealer (ugh...) either can’t get it to replicate the issue consistently, or tells me they “can’t just start throwing parts at it.” They also tell me that I’ll freeze up the circuit (or something like that) if I press the buttons too many times in a row, but Ive apparently just started mistreating my locks recently to cause this problem LOL, no issue until now since February 2020 when I got the car. There’s no bulletin out for this. They did a software update and also replaced the fob battery and reprogrammed the fob to to avail. Anyone have any insights? Thanks in advance!! 😎

Other recent issues:
  • Units of measurement change to Metric units from Imperial upon startup, I go to settings and “US” is checks but all units (speed, gas mileage, temperature) are showing in metric. Happens every 2-3 weeks randomly and I have to manually change the setting back.
  • Fog light randomly goes out aside from normal driving function.
  • Wouldn't start recently, engine cranked but wouldn’t turn. All accessories worked normally, no signs of low battery/battery tested fine. Tow driver got car started, may be a low oil issue? Dealer couldn’t replicate, gave car back after doing an oil change, oil was a little low. Problem for another thread, I suppose. 🙃
230580
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
Here’s a picture of the crazy units being set as US units of measure, but everything in my dash showing metric. Not sure if that’s related to the locks, the unit reset has been happening long before the locking issue.
230581
 

·
Registered
Joined
·
1,944 Posts
Here’s a picture of the crazy units being set as US units of measure, but everything in my dash showing metric. Not sure if that’s related to the locks, the unit reset has been happening long before the locking issue.
View attachment 230581
This definitely sounds frustrating, Kamschne. When was the last time you brought your Jeep to the dealer? We would be happy to discuss your situation further, send a private message when you have a moment.

Kate
Jeep Cares
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
This definitely sounds frustrating, Kamschne. When was the last time you brought your Jeep to the dealer? We would be happy to discuss your situation further, send a private message when you have a moment.

Kate
Jeep Cares
It’s currently at the dealer for the second time in two weeks. They said it wouldn’t start because the oil was low (though I haven’t hit the 1 year/10k miles/Oil Change Due light point yet). They can’t get the locks to replicate the issue. I believe the locks act up when it is damp and cloudy outside.
 

·
Registered
Joined
·
1,944 Posts
It’s currently at the dealer for the second time in two weeks. They said it wouldn’t start because the oil was low (though I haven’t hit the 1 year/10k miles/Oil Change Due light point yet). They can’t get the locks to replicate the issue. I believe the locks act up when it is damp and cloudy outside.
Sorry to hear that, Kamschne. If you'd like our team to look into this, send us a PM.

Kate
Jeep Cares
 
1 - 5 of 5 Posts
Top