Jeep Garage  - Jeep Forum banner
1 - 20 of 30 Posts

· Registered
2014 JGC Summit
Joined
·
70 Posts
Discussion Starter · #1 · (Edited)
After leaving the dealership service department for another issue, I was driving around and suddenly started receiving this error message and random "BRAKE" messages from the FCW system. I pulled over to clean the radar sensor and noticed the plastic square molding with the round cutout around the radar sensor was no longer on the truck. I'm not sure if it was removed and never put back on by the service tech, or it popped off by itself.

By the time I realized what was wrong, the service department was already closed. I'm assuming the missing piece is causing the error messages. I'll update this post when I get a chance to go back to the dealership again. Just figured I'd share with you guys if you ever come across this.
 

Attachments

· Premium Member
Joined
·
4,989 Posts
After leaving the dealership service department for another issue, I was driving around and suddenly started receiving this error message and random "BRAKE" messages from the FCW system. I pulled over to clean the radar sensor and noticed the plastic square molding with the round cutout around the radar sensor was no longer on the truck. I'm not sure if it was removed and never put back on by the service tech, or it popped off by itself.

By the time I realized what was wrong, the service department was already closed. I'm assuming the missing piece is causing the error messages. I'll update this post when I get a chance to go back to the dealership again. Just figured I'd share with you guys if you ever come across this.
Interesting, Please post a picture of that piece missing.

Thanks!
 

· Registered
2014 JGC Summit
Joined
·
70 Posts
Discussion Starter · #3 ·
Interesting, Please post a picture of that piece missing.

Thanks!
Sorry it took so long to reply, I was away on vacation. The first picture is what it is supposed to look like. The second picture shows the missing piece on my truck. I brought it to the service department today and they have to order the part. They "strongly feel" the missing cover is causing all of the error messages. I'll post the results when the part comes in.
 

Attachments

· Premium Member
Joined
·
4,989 Posts
Sorry it took so long to reply, I was away on vacation. The first picture is what it is supposed to look like. The second picture shows the missing piece on my truck. I brought it to the service department today and they have to order the part. They "strongly feel" the missing cover is causing all of the error messages. I'll post the results when the part comes in.
Yes the alignment is off and the piece provides a reference angle for the view of the sensor. They are correct, it is very likely this is the cause.

As another poster noted, I wonder if this has happened before?
 

· Registered
Joined
·
8 Posts
Thanks Edwin! I had the same error messages, and after reading your post I remembered that a couple of days ago I brushed against something when entering my garage. I went to take a look and sure enough the part was missing from my truck as well. I ended up finding the molding next to a cooler.
 

· Registered
2014 JGC Summit
Joined
·
70 Posts
Discussion Starter · #8 ·
Thanks Edwin! I had the same error messages, and after reading your post I remembered that a couple of days ago I brushed against something when entering my garage. I went to take a look and sure enough the part was missing from my truck as well. I ended up finding the molding next to a cooler.
Glad the post helped you! Take care.
 

· Administrator
Joined
·
11,967 Posts
Maybe whatever caused the shroud to come off also damaged the sensor?
 

· Registered
2014 JGC Summit
Joined
·
70 Posts
Discussion Starter · #11 ·
Unfortunately I'm still getting the error message, even after putting the molding back on and wiping off the sensor.
When that piece fell off of my truck, I brought it back to the dealership. The dealership stated the bracket holding the radar sensor was damaged, causing the radar sensor to move and become misaligned. It appears since the radar sensor bracket was broken, the moving of the sensor popped the plastic molding off of the truck. Sorry to say, but it took a few weeks for the part to come in and a day or so aligning the sensor. Good luck.
 

· Registered
2014 JGC Overland
Joined
·
225 Posts
My Cruise and ACC workes fine...EXCEPT....when I hit "resume" after braking, then I get the "ACC/FCW needs service warning". I just needed to shut cruise off then restart and all was well.

Yesterday I looked at the square molding referenced here and sure enough the top part was protruding about to fall off. I put back in place and tested on interstate and sure enough, problem went away.

Kudos to this sight and thread for helping me avoid trip to dealer for such an easy fix.

Chuck
 

· Registered
Joined
·
34 Posts
I have a GC 2012 diesel and had a similar issue.
Problem s I have ascertained is that when parking that the front bumper actually had touched the garage wall. Sensor originally showed i still had one bar showing but actually touched the wall. No visible damage but driving next day square bezel around radar sensor moving causing error messages FCW / eTC.

After pulling plastic under cover off front bumper bar found that because of the light bump on the plastic front bumper their is 3 screws holding the radar sensor. They are easily popped as they are only held in by a plastic grommet which each thread screws thru. Unless checked and are firmly in place the sensor will slightly distort its level even with square bezel in place.
If you still get error messages FCW etc it is one of the 3 metal screws which are held in place by a plastic insert that hold the radar sensor is still loose- causes radar sensor to either pick up road to the left or right or elevation is down.
The parts look minimal- just a plastic grommet which one off the small screws screw into needs replacing.

Hope this helps -
Strategy from Australia:thumbsup:
 

· Registered
Joined
·
24 Posts
At 9600 miles I began to receive FCW/ACC errors to wipe radar, pull over to wipe and radar protective shroud missing. I did not hit, nor was I hit with anything that I am aware of. Took to dealer and the service manager looked at it with a befuddled look and then said he would order a new cover under warranty. Hopefully system will work correctly once new cover is installed. Been waiting 3 days now for the part to come in. Will update after part installed. It's nice that parts just fall off a 50k vehicle.
 

· Premium Member
Joined
·
3,255 Posts
Hi all

has anyone fitted a bull bar and looked at moving the ACC sensor from a very exposed bottom location to the top of the bumper bar section of a bull bar?

Gazz
Ummmmmmm......that doesn't sound like a good idea unless you are going to disable the ACC system and not use it. I would bet you can't just relocate it and have it work like it should since it is calibrated / work in conjunction with a camera on top.
 

· Registered
Joined
·
24 Posts
Follow up to ACC/FCW errors and missing shroud at 9600 miles. Turns out my radar eye must have been hit with road debris as dealer claims radar camera eye is damaged as well as mounting bracket screw - replacement unit with installation is 1600$. Thankfully my dealer is completing this entirely under warranty. Obviously these units are very vulnerable due to physical location.
 

· Registered
Joined
·
2 Posts
I have a 2014 GJC O Diesel with 28000 miles. started getting the ACC/FCW "lens needs cleaning" warning. took to the dealer. They said the trim is missing and the lens shows impact damage, and submitted it to Chrysler for warranty, but it was denied because of impact damage. suggested I process the $1850 cost through insurance. I don't recall hitting or being hit by anything. Seems that Chrysler may have a poor design on its hands. How do we go about requesting an engineering investigation for a Chrysler fix? any ideas?
 

· Administrator
Joined
·
11,967 Posts
bsc', unfortunately, anything located in that particular area is susceptible to physical damage from road debris, etc., whether it's electronic in nature or just visual trim. It's always been that way on vehicles and always will be that way. The fact that a trim part is actually missing and evidence of physical damage to the sensor is evident unfortunately isn't a design issue. "Something" caused that damage and it's unlikely that Chrysler or any other manufacturer would take responsibility for that under warranty. There is likely a specific exclusion for that in the warranty language, too.
 

· Registered
2014 Summit 5.7
Joined
·
3,938 Posts
I have a 2014 GJC O Diesel with 28000 miles. started getting the ACC/FCW "lens needs cleaning" warning. took to the dealer. They said the trim is missing and the lens shows impact damage, and submitted it to Chrysler for warranty, but it was denied because of impact damage. suggested I process the $1850 cost through insurance. I don't recall hitting or being hit by anything. Seems that Chrysler may have a poor design on its hands. How do we go about requesting an engineering investigation for a Chrysler fix? any ideas?
Wow $1850, the trim ring is just plastic with minimal cost and fairly easy install on the sensor so that sensor part sure has a heavy price tag.
 
1 - 20 of 30 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top