Jeep Garage  - Jeep Forum banner

1 - 9 of 9 Posts

·
Registered
Cherokee
Joined
·
4 Posts
Discussion Starter #1
2019 Cherokee 6000 miles.
At about 5800 miles odometer began flashing. Noticed automatic high beams, lane assist, adaptive cruise control all inoperative. On startup a quick message is flashed "ACC/FCW limited functionality" and to get serviced. Car runs fine otherwise.

This did not go away on its own after daily restarts. Windshield and forward grill radar clean and undamaged.
Dealer decided to replace forward camera, although I don't know based on what information. Camera replaced, software updated "although they had two days when their garage "hotspot" would not work. Another day lost when a serviceman locked away a needed tool? Another day due to rain preventing calibration. Finally, unable to calibrate camera while on a good road in good weather. Originally thought it was weather and traffic, and evening darkness related. Now they are wondering if the "hotspot" issue was related to the failure to be able to calibrate issue. Escalated to the STAR center...and now we will see what happens.
After a lot of reading on this site and other jeep problem posts, I'm pretty sure there is a lot of unknown complexity for this issue and related camera/radar problems, and even large service centers are unable to understand it. Different software releases, and model years probably behave differently and error messages and codes can be varied.
Not to thrilled to be a "first time we've had this issue" customer.
I come from the days when at least I could get at something with a wrench or stand there with my mechanic and see where the oil leak was coming from. :confused:
 

·
Registered
Cherokee
Joined
·
4 Posts
Discussion Starter #2
Followup on my ACC/FCW problem.
35 days later I get my 2019 Cherokee back from the shop!
The problem was that they COULD NOT calibrate the forward camera. They worked with FCA through STAR to troubleshoot it. Resolution MAY have been a wiring connection issue. Substantial work including in the dashboard was required, and removal of front fascia.


I will need to look closely for return of any issues, and/or damage to my vehicle from the service efforts.


All service was covered under warranty.


I am filing for breach of contract under Lemon Law for diminished resale value. This really pissed me off. 35 days with national service support assistance to fix this issue?
And maybe still they don't know what the cause was.
 

·
Registered
Joined
·
1 Posts
I am having the same issue at 6,000 on my 2019 Cherokee Overland. Taking it in tomorrow. Hope I have better luck than you did? 2nd warranty issue in 6 months of ownership.
 

·
Registered
Joined
·
1,990 Posts
I am having the same issue at 6,000 on my 2019 Cherokee Overland. Taking it in tomorrow. Hope I have better luck than you did? 2nd warranty issue in 6 months of ownership.
Hi Jon Simpson,
We are sorry to hear that you are experiencing this. If you would like any additional assistance while your Jeep is in the shop, please feel free to send us a private message.
Alex
Jeep Social Care Specialist
 

·
Registered
Joined
·
4 Posts
The saga continues. :/
On my new 2017 GC I got the error message after three months of ownership. Took it in and said camera was faulty and took 3 weeks to get a replacement, all under warranty. Worked fine for 3 years but has now gone out again / get same error message. Dealer says I need another new camera and since 3Y/36k warranty has expired it’s a $1800 fix, which I probably won’t do given now two cameras have been faulty and it’s a non-core function, albeit one I paid for. Was hoping the surrounding frame has falllen out as was suggested on other threads but no such luck.
 

·
Registered
Joined
·
1 Posts
2020 Gladiator with 180 miles or less on the vehicle. I have seen this pop up literally every time we drive it. Windshield and sensors are all clean.
Also the speedometer went ape shit and was acting like a tachometer not a speedometer. That has since "calibrated" itself back to normal.
 

·
Registered
Summit
Joined
·
72 Posts
Same problem with my 2016 Summit. Seems to happen in cold (20 F ) weather. A real pain because the alarm is annoying. Sometimes shutting the vehicle off and restart will stop it. Is there any new data on this problem? Wondering if a different radar unit might help? does anyone know if swapping that would be plug n' play ?.....Mike.
 

·
Registered
Joined
·
23 Posts
I drive a 2020 Trailhawk Grand Cherokee and this same message started to pop-up today. This is the third problem I have with the Jeep (the other two problems are still not fixed) and am starting to regret the purchase. I'll make an appointment with the service department and report back with any update.
 
1 - 9 of 9 Posts
Top