Jeep Garage  - Jeep Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
385 Posts
Discussion Starter · #1 ·
has anyone installed a aftermarket headunit using the PAC C2R-CHY me and my boy were intalling it yesterday headunit turns on seems like everything works but no sound if you guys havent used the C2R-CHY what did you use and how easy was the install im oretty electronic savvy but this jsut boggles my mind i hate CANBUS why cant it be easy like older models... by the way 05 GC with BA system
 

·
Registered
05 WK Laredo
Joined
·
1,928 Posts
has anyone installed a aftermarket headunit using the PAC C2R-CHY me and my boy were intalling it yesterday headunit turns on seems like everything works but no sound if you guys havent used the C2R-CHY what did you use and how easy was the install im oretty electronic savvy but this jsut boggles my mind i hate CANBUS why cant it be easy like older models... by the way 05 GC with BA system
Did you hook-up the front speaker outputs of the radio to the rear inputs of the 22 pin connector? The rear speaker outputs of the radio are not used. Note that the factory amplifier only has a two channel input. When connecting an aftermarket stereo, only two channels can be used. Therefore, the fading capability of the aftermarket stereo will not be able to be used.

http://www.installer.com/pdf/c2r-chy.pdf

I have the Pac you have, but I dont have the BA system and im also running pre-amp outputs instead of the speaker wiring.
 

·
Registered
Joined
·
385 Posts
Discussion Starter · #3 ·
yea we did that this sjut boggles my mind its so frustrating i ahve all ym cables runn for my subs and everything good to go and this is the only thing holding me back
 

·
Registered
05 WK Laredo
Joined
·
1,928 Posts
Hard to tell without being there to see it myself, and just going on what you say. I would go back and triple check all the wiring, connectors and all. Make sure the remote wire on the Pac is connected to the radio's amp trigger wire, and go back and see if the amp is actually turning on. If your amp is turning on then test the speaker wires, working back to the head unit.
 

·
Registered
Joined
·
385 Posts
Discussion Starter · #6 ·
thanks alot Timmy were going to get abck to working on it on tues so hopeully we can figure it out and get everything up and running thenand then will come the pics well hopefully
 

·
Registered
05 WK Laredo
Joined
·
1,928 Posts
Awesome, good luck. Im in the middle of doing my system too, and when i run into problems I know how frustrating it can be. But like I said, if you have a volt meter to be able to test the wiring then your not guessing as much.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top