Jeep Garage  - Jeep Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My 2018 Jeep Grand Cherokee Altitude recently had what I thought was a dying battery. While running in my driveway I got a “Stop Safely, Car will shut off shortly” warning. Then a multitude of warnings came on screen, push button stop wouldn’t even let me turn it off.

I put both batteries on charger and they both tested at appropriate levels afterwards. After reinstalling, the car would not start. All electronics turn on but it won’t turn over. I tried putting jumper cables on Auxillary battery and it started right up.

So I figure must need a new battery. After installing brand new aux battery, same issue. Won’t start. Put jumper cables on new aux battery, starts right up. After it starts up I still have the battery low light on and the start/stop unavailable warning.

Any ideas?
 

·
Registered
Joined
·
189 Posts
My 2018 Jeep Grand Cherokee Altitude recently had what I thought was a dying battery. While running in my driveway I got a “Stop Safely, Car will shut off shortly” warning. Then a multitude of warnings came on screen, push button stop wouldn’t even let me turn it off.

I put both batteries on charger and they both tested at appropriate levels afterwards. After reinstalling, the car would not start. All electronics turn on but it won’t turn over. I tried putting jumper cables on Auxillary battery and it started right up.

So I figure must need a new battery. After installing brand new aux battery, same issue. Won’t start. Put jumper cables on new aux battery, starts right up. After it starts up I still have the battery low light on and the start/stop unavailable warning.

Any ideas?
I’ve read elsewhere of others having similar issues with the smaller battery.
 

·
Registered
Joined
·
14 Posts
The dealership said somehow I must of crossed the cables or something when reinstalling the batteries and it ended up blowing a fuse block. I thought they said the fuse block was accessed under a fender, so not the one up top in the engine bay.
I was in such a hurry I didn’t bother looking into it much.
 

·
Registered
Joined
·
3 Posts
Please please pleaseeeeee tell me what they did!! Identical issues to you!! Been tryimg track down what the he'll happened. I have isolated the no charge or voltage to the aux battery from before the box under hood, through the firewall and down to the aux battery. I'm lost!!! I just replaced the aux battery due to start stop light coming on. After that I've had am electrical nightmare for 3 days now!! It's not a customers of mine either, it's my fiances car!! So I still hear about it when I get home!!! Pleassseeeee!!! Need some rest! Lol
 

·
Registered
Joined
·
3 Posts
Please please pleaseeeeee tell me what they did!! Identical issues to you!! Been tryimg track down what the he'll happened. I have isolated the no charge or voltage to the aux battery from before the box under hood, through the firewall and down to the aux battery. I'm lost!!! I just replaced the aux battery due to start stop light coming on. After that I've had am electrical nightmare for 3 days now!! It's not a customers of mine either, it's my fiances car!! So I still hear about it when I get home!!! Pleassseeeee!!! Need some rest! Lol
It's a 2020 jeep grand cherokee as well
 

·
Registered
2014 Summit 5.7 4wd 20" tires swapped to 18", added all skid plates
Joined
·
2,750 Posts
It's a 2020 jeep grand cherokee as well
Someone else may pop in with better info but in the meantime .... there was a thread about a similar problem to yours and what was found was that the "thing" under the hood which has the handy terminal so you can jump start the vehicle also has a very large fuse inside of it. I don't recall the details but if you have the time see if you can open that part up and look for a large fuse. I don't think it shows on the electric wiring diagrams.
 

·
Registered
Joined
·
3 Posts
Someone else may pop in with better info but in the meantime .... there was a thread about a similar problem to yours and what was found was that the "thing" under the hood which has the handy terminal so you can jump start the vehicle also has a very large fuse inside of it. I don't recall the details but if you have the time see if you can open that part up and look for a large fuse. I don't think it shows on the electric wiring diagrams.
Thank you so much! I was looking at it. Had even pulled it off where it's mounted.. I saw the thread you're talking about.. but ironically enough .. from that point ..to the aux battery is where I've got no power .. I've been scanning all the wires from that point..to the battery .. for any kind of break In . Bare wire .. anything!! I've replaced the aux battery 4 tines.. the power control relay .. the battery sensor..twice .. lol.. the main battery.. I've looked for a relay on the fender well someone has mentioned and never found.. but that would make perfect sense.. there is 3 wires running in through the bottom of that piece.. but I didn't know it comes apart and there be a fuse in it .. very helpful! Thank you!!
 
1 - 7 of 7 Posts
Top