Jeep Garage  - Jeep Forum banner
1 - 2 of 2 Posts

·
Registered
Jeep Cherokee 2014
Joined
·
3 Posts
Discussion Starter · #1 ·
:( just wondering if anyone with a Cherokee 2014 Ltd Diesel has had a electronic throttle issue. we keep getting a "service electronic throttle" warning flashing, the little engine light stays on on the dash & car goes into limp mode.

took it to the local jeep dealer in caroline springs victoria, australia & they confirmed it was oil that has got into the vaccum lines & pump & they now advised replace all vacuum lines, vacuum pump, etc at an estimated cost of $10k.. I had a slight heart attack .. the car is 3.5 years old and done 60k kms ... how can this be ?

i'm am now waiting on a reply for the caroline springs jeep dealer on a goodwill request to Jeep Australia. A price of $10k is disgusting to fix a car 3.5 years old with 60k kms on it.

I have spoken to 2 independents about the issue (describing the exact details that need to be replaced from the documentation the dealer provided) and both confirmed what was explained by the dealer does not make sense.

I am that surprised it would cost $10k to replace these parts, but at the same time not surprised after reading many forums on jeep dealers. the caroline springs dealer wants to charge $563 to replace 1 headlamp ... i did a bit of searching around to discover a replacement would cost between USD $99 – $200 for the exact part depending on where you buy it from. in my research on my issue some say it is as simply as a loose clip that could cause the issue / others have gone as far to say the dfp (or dpf) is the issue. what do you do ?
 

·
Registered
Joined
·
1 Posts
Hi I’ve had the same issue with my 2014 summit, mechanic had put it on scan and code came up that my Excelerator pedal was faulty have had 2 second hand pedals on it only two twice till I had it towed to Peter warren Jeep and had said pedal had an Internal fault so they rang around and told me due to covid and trying to get a new one would take 3 mths to receive so they put an after market one on it lasted 4 weeks till my engine light and and lighting bolt sign came on with service Electronic throttle body again but when I was starting the vehicle I could hear a noise come from within the dash sounding like Electrical fault buzzing noise it’s at Jeep again and they say it’s something electrical but they have had the vehicle for two weeks with an Electrician looking for the problem and still no luck.
Has anyone had a problem like this
 
1 - 2 of 2 Posts
Top