Jeep Garage  - Jeep Forum banner

1 - 5 of 5 Posts

·
Registered
2005 GC Laredo
Joined
·
657 Posts
Discussion Starter #1
I was hoping you guys could help me out. I have the K&N intake setup for my 4.7. Anyway it was a nice day so I went to clean my engine bay, open the hood, and the filter was laying in the box not connected to the tube anymore. I have no idea how long it was like this for. How badly do you think I damaged my engine? I plan to change the oil now but is it too late? K&N needs a better system, no matter how tight i clamp it on it seems to eventually fall off.
 

·
Registered
Jeep wk
Joined
·
2,015 Posts
you probably did not damage it at all if its running fine right now. my friends one fell off in his vw gti and it could have been off for months. everything was fine. I agree k and n needs a better clamp to keep them on.
 

·
Long Live the Grey Ghosts
Joined
·
13,492 Posts
change your oil a bit extra and you will be fine.

i ran a harley for thousands of miles with a velocity stack. i just never went more than 1000 miles before I changed the oil.
 

·
Registered
2005 GC Laredo
Joined
·
657 Posts
Discussion Starter #4
Thanks guys, i'll change the oil and filter this weekend.
 

·
Registered
2010 JEEP SRT8
Joined
·
1,742 Posts
Not having filtered air going into your engine will not do much to dirty your oil,but it will let in particulates (dirt/ grit) that can scuff up your nice smooth sealing surfaces - valves, cylinders/rings...
if you havent/ dont drive in the dirt/dust much, you shouldnt have an issue.
 
1 - 5 of 5 Posts
Top