Jeep Garage  - Jeep Forum banner
1 - 1 of 1 Posts

· Registered
3 Posts
Discussion Starter · #1 ·
Hello All,

Two months ago my wife Gloria and I purchased (2nd hand) a 2012 WK Series Jeep Grand Cherokee v6 Diesel Laredo with 14000km on the clock. Our Jeep, which we chose specifically to tow our 17' Jayco Pop-Top Van, is still very new to me and I am learning all the time.

Having made the purchase the first thing we did was to get a Jeep dealership to set it up for towing ...complete from tow bar to Andersen plug etc. Last weekend we undertook our first short test trip with van in tow. However we struck a problem on the return trip home as describes below:

Our home town is Ipswich, Queensland Australia. We first drove a distance of 108km (without incident) and setup camp for the night. On the drive to camp I used cruise control set on 90kmph which worked well. I did not use it when climbing the winding road up to the National Park. Having stayed overnight, the next morning we drove back to Fernvale again without incident. I did not use cruise control while descending but I did use it between Esk and Fernvale again without incident. At Fernvale we stopped for an hour or so.

When we departed Fernvale as soon as I got to the 100km zone I engaged cruise control and set it at 90kph. Within a short period of time I noticed the vehicle progressively loosing speed. As there was a queue of cars behind I did not disengage cruise control but instead used my foot on the accelerator in an attempt to bring the vehicle back up to 90kmph …by this time vehicle speed had dropped to 80kph. At first I got no response from the accelerator (which alarmed me) as I gently applied it pushing it almost to the floor. Eventually it kicked in but this took 30 seconds or so which seemed like an eternity. I was then able to bring the vehicle back up to 90kph. I tried cruise control on and cruise control off for the next 15km …the issue persisted.

I didn’t say anything to my wife but I think she sensed there was an issue. However when my wife complained of a burning smell I immediately stopped and checked the wheels on both the caravan and the Jeep none of which were hot. I lifted the bonnet. I could not smell anything nor could I see any tell-tale signs. I lay on the ground and checked under the vehicle …everything appeared to be in order. This took about five minutes. Next I tentatively drove the remaining 18km home at 80kmph – we chose not to run the air-con or to use cruise control. We had all the windows down listening for any noise or smell but we heard and smelt nothing unusual. During this last 18km I did not sense the issue …in other words the vehicle seemed to perform as per normal. However I was driving it ever so gently as I knew there was an issue.

I have tried to be as factual as possible as I don’t want to give you a bum steer regarding the symptoms we experienced so I want to clarify these points (a) the issue definitely occurred whilst cruise control was engaged and (b) the issue continued immediately after cruise control was disengaged. Within the 'issue period' it was as if the accelerator did nothing …the engine did not roar or increase RPM even though I pressed the accelerator way down. There were no alarms visible on the dashboard screen.

I didn't include Automatic Gearbox/Oil level in the title. I have absolutely no idea what the issue is so please don't let the title limit your thinking. There must be a logical solution. Hopefully one of you will recognize the symptoms I've described above. Have any of you heard of this before?

I should mention that I have spoken to service mechanics at three separate Jeep dealerships ...none of them recognized these symptoms. I have the vehicle booked for diagnostic work next Wednesday. I have asked them to check the level of the Automatic Transmission Oil as well as the computer diagnosis.

Kind Regards,
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.