Jeep Garage  - Jeep Forum banner
1 - 4 of 4 Posts

·
Registered
WK2 HA EcoDiesel
Joined
·
1 Posts
Discussion Starter · #1 ·
Today when i left to go pickup my girlfriend from the airport my unconnected 8.4 stopped working on startup. Took it to the dealer and they told me maybe disconnect the battery to reset it so i did. Now my air conditioning is all messed up. Startup the ac will work for about 30 seconds and then the front and rear defrost turn on and you can't change them. I have to drive home from vacation for 13 hours and would like AC. Any ideas to remedy this. The dealer says they can't meet my need by me leaving on Tuesday.

Any fuse recommendations to pull so this wouldn't happen?
 

·
Registered
Joined
·
2,147 Posts
Today when i left to go pickup my girlfriend from the airport my unconnected 8.4 stopped working on startup. Took it to the dealer and they told me maybe disconnect the battery to reset it so i did. Now my air conditioning is all messed up. Startup the ac will work for about 30 seconds and then the front and rear defrost turn on and you can't change them. I have to drive home from vacation for 13 hours and would like AC. Any ideas to remedy this. The dealer says they can't meet my need by me leaving on Tuesday.

Any fuse recommendations to pull so this wouldn't happen?
Hi indywk2,

Sorry to hear about this! Please don't hesitate to send us a PM with any questions or concerns that may arise during your dealership appointment.

Andrea
Jeep Social Care Specialist
 

·
Registered
Joined
·
2 Posts
Today when i left to go pickup my girlfriend from the airport my unconnected 8.4 stopped working on startup. Took it to the dealer and they told me maybe disconnect the battery to reset it so i did. Now my air conditioning is all messed up. Startup the ac will work for about 30 seconds and then the front and rear defrost turn on and you can't change them. I have to drive home from vacation for 13 hours and would like AC. Any ideas to remedy this. The dealer says they can't meet my need by me leaving on Tuesday.

Any fuse recommendations to pull so this wouldn't happen?
Hi Indywk2, I know your issue was a while ago but I'm experiencing the exact same problem & interested to find out what your solution was?
 

·
Registered
Joined
·
2 Posts
Hi Indywk2, I know your issue was a while ago but I'm experiencing the exact same problem & interested to find out what your solution was?
Update: I had this guy in NZ (https://www.mcallisterradiorepairs.co.nz/) take a look at my wk2 uconnect radio, he diagnosed & replaced a popped protection diode in the radio - All fixed for $40!!! Happy man!:)
 
1 - 4 of 4 Posts
Top