Jeep Garage  - Jeep Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
167 Posts
Discussion Starter #1
Hi guys,
Got in the car today and as I drove off, I noticed that the e-brake light had not turned off and was flashing. Thinking I had just forgotten to take it off, I checked, but it was not engaged. So basically, it is flashing for no apparent reason. It has done this before, however rectified itself the next time I turned the car on. It's been 3 days now and it hasn't stopped. Last time, I put it down to the fact that I was pushing in the e-brake harder than normal as there was a bit of roll so I wanted to make it tighter. However, I tried to push it in not quite as far again but it is still flashing. Thoughts?
 

·
Registered
Joined
·
373 Posts
Try doing the opposite. Push the parking brake down as far as you can and releasing it a few times. Sometimes, things can bind up a bit, particularly in inclimate weather. Has worked for me every time. I never use my parking brake in the winter unless I absolutely have to.
 

·
Registered
Joined
·
167 Posts
Discussion Starter #4
Padgett: I do not have ACC

Justal: Considering I live in Australia, it isnt exactly snowing right now... but we have had a lot of rain lately, so I'll give it a go
 

·
Premium Member
2017 Summit
Joined
·
8,842 Posts
This is just a guess based on experience with some older cars. The same light that when on, solid, indicated the emergency brake was engaged, when flashing indicated a problem with the brake system.

At the very least I would say take a look at your brake fluid level.
 

·
Registered
Joined
·
167 Posts
Discussion Starter #7
padgett: it's 100% computer generated

bill: i've looked at the fluid levels, all good - i will take it to a dealer as soon as i get a chance just in case it is a major system problem
 

·
Registered
Joined
·
498 Posts
My 2012 JGC did a similar thing. The brake light stayed on and a single chime sounded. Checked the parking brake and it was released. Cycled it a couple of times and light stayed on. Not flashing but just on. Took it to dealer and they reset the light and checked fluids and a seal in the master cylinder. (TSB) They said if it happened again to call them. Went about two weeks trouble free and then it came on again for a whole day and now its off. Have a scheduled appt. to have it checked again. Frustrating.........
 
1 - 9 of 9 Posts
Top