Jeep Garage  - Jeep Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2007 Grand Cherokee with 3.0l diesel and 125,000 miles. Mostly troublefree with a good amount of towing until this summer.
While towing 6500lb. boat trailer the red “electronic throttle control” light started flashing, and it went into limp mode. Also got Code P0299 (underboost)
Jeep dealer replaced turbo and fixed boost leaks with new intake pipe assy. Also replaced one injector.
It runs fine now around town, but after about 20 minutes at freeway speeds, the ETC light starts flashing with limp mode following.
Any suggestions?
Thanks
 

·
Registered
Joined
·
146 Posts
I have a 2007 Grand Cherokee with 3.0l diesel and 125,000 miles. Mostly troublefree with a good amount of towing until this summer.
While towing 6500lb. boat trailer the red “electronic throttle control” light started flashing, and it went into limp mode. Also got Code P0299 (underboost)
Jeep dealer replaced turbo and fixed boost leaks with new intake pipe assy. Also replaced one injector.
It runs fine now around town, but after about 20 minutes at freeway speeds, the ETC light starts flashing with limp mode following.
Any suggestions?
Thanks
It could be several things, but don't rule out an electrical problem... even seemingly unrelated to the "electronic throttle control". I had the dreaded ETC flashing problem and limp mode a couple times on our 2008 CRD. The dealership first replaced a transmission electronic module of some sort (sorry I don't remember without pulling out the service records from a couple years ago), but the problem came back a couple months later when cold weather hit, but this time with a few other messages related to 4WD-LO if I remember correctly. I forget the details now, but something led me down the path of the transfer case motor and I ended up pulling the transfer case motor off and inspecting the electrical connection. I found that one of the male pins was not seated properly in the plastic injection molded connector and was kind of floating around... making and sometime not making good contact. I ended having to replace the entire transfer case motor and all has been well for about a year. Good luck, because in general we've very much enjoyed ours for more than 12 years.
 

·
Registered
Grand Cherokee WK
Joined
·
6 Posts
Did the dealership replace the turbo actuator as well? Its sold as a unit new so hopefully they did but if you were having it rebuilt or trying to shave some cost, they may not have swapped your actuator (the little black box attached to your turbo, easy to spot). The ETC light on our CRDs is almost always related to the turbo actuator failing and there are companies out there that can repair yours or CORE charge you for a replacement.

I got my 2007 CRD about three years ago at 99k miles. Year one was rough (transfer case motor, throttle body, couple glow plugs, injector pump, 6 injectors and my entire turbo+actuator all replaced) but my extended warranty actually covered the whole thing, which seemingly never happens. To top it off my water pump died with 66 miles left on my warranty, phew!

Since then it's been FANTASTIC! Little bit of work here and there, plus one asshole blowing through a stop sign but I plan on keeping this vehicle over my others for years to come.

It likely threw a OBD code, even if the check engine light didn't chime.
Does your 4Lo work?
If it takes 20 min at highway speeds, is something is overheating?
How about the swirl motor?
 
1 - 3 of 3 Posts
Top