Jeep Garage  - Jeep Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Hoping someone can help with this. I have been getting the esc,abs,service 4 wheel drive lights lately. The brake pedal pulses as well. Had the codes pulled this morning. The front left abs sensor has gone bad-got that one. But some of the codes have me stumped. U0100,U0101 lost ECM and Tcm communication, any ideas on this? Also U140E, and B2202 these I can't find and have no idea what they are. The person at Advance Auto that pulled the codes also said the battery showed low-B2100. Could anyone offer some guidance on the U140E and B2202? Also the P0700 code popped up. Thanks for any help with these.
 

·
Registered
2005 Grand Cherokee
Joined
·
1,019 Posts
WK's have an infamous slew of electrical issues related to low battery voltages. If your battery is shite, I'd start by replacing it with a new one. It's quite possible that this fix could resolve the rest of your codes.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #4 ·
I'm going to replace the battery tonight and hope that resolves it. I looked at the abs sensor on the front wheel and it looks like a lot of fun to do. Looks like the front wheel,rotor and all have to come off. After the battery I will fill you in on the progress. Thanks for the help
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #5 ·
Update-the lights have gone away for the most part. Still getting them once every couple days. Stutter in the brake pedal occasionally. To replace the abs sensor on the front, do the brakes have to be bled?
 
1 - 5 of 5 Posts
Top