Jeep Garage  - Jeep Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
546 Posts
Discussion Starter · #1 · (Edited)
Had my 2017 JGC limited for about 4.5 months now with 3300 miles on it, bought brand new from dealership. I was coming home yesterday from a trip to P.A. and was on the road for a little more than three hours with the GPS on and everything was working fine then the system froze up on me and I got the start up screen which said searching and the smaller dashboard screen by the wheel was also frozen on the last command given. The rest of the ride home it stayed like that. I turned the screen off and on and played with some settings but it didn't change. I got home, turned the car off, let it sit for a couple minutes and restarted it and the screen cleared and everything went back to normal, kind of like resetting your cell phone if it freezes up. I know these things happen with computers once in a while and restarting it usually does the job. Has anyone else ever had their GPS just freeze up on them while traveling somewhere?? I would have just pulled over and restarted it but was making good time and I knew where I was going so didn't want to stop and loose time.
 

·
Registered
Joined
·
507 Posts
They all will do this on rare occasions. I took a 2200 mile trip with my gps on the entire time and no issues. If you do get a glitch: Always turn your car completely off, open and close the drivers door and wait 15 seconds. When you restart your car, it will probably clear up any gps or Uconnect issues. If that doesn’t work you can do a soft reset to the system. All high tech vehicles get these momentary glitches just like your smart phone. If it happens regularly, you should contact your Uconnect service for info. They might send a refresh over the air to clear it up or advise you to see your dealer.
 

·
Premium Member
Joined
·
3,402 Posts
I've had this happen to my Uconnect a few times over the years. I pulled over and recycled the vehicle as mystro suggested, and that worked. But I've found a reset while driving can be just as effective. Just push the volume and tuning knobs in simultaneously, and hold in till the reset starts. This resets the system without pulling over and restarting the vehicle.
 

·
Registered
Joined
·
546 Posts
Discussion Starter · #4 ·
I've had this happen to my Uconnect a few times over the years. I pulled over and recycled the vehicle as mystro suggested, and that worked. But I've found a reset while driving can be just as effective. Just push the volume and tuning knobs in simultaneously, and hold in till the reset starts. This resets the system without pulling over and restarting the vehicle.
Good to know, thank you.
 
1 - 4 of 4 Posts
Top