Jeep Garage  - Jeep Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
For the past week or two, when the jeep hasn't been driven for several hours and is cold. When ever I back out of my spot and go to full lock to get out of the space, the jeep stops moving on its on and makes an almost tire rubbing sound in the front, no evidence if rubbing and on stock wheels and tires, and suspension. And when moving foward it does Not want to turn, I can still turn but it has resistance, and whips back quicker than it should. Will only do this for 100 yds and stops then drives normal , any ideas? I have a 2010 GC 5.7 w/ quadra drive II any help is appreciated
 

·
Registered
2005 Grand Cherokee
Joined
·
1,019 Posts
Sounds like what happens when your transfer case engages in 4LO. Your turning radius being affected means it's likely that your front differential is actually working via the transfer case. I'd start there (i.e. make sure you're in regular drive without 4LO, etc). If that's not it, sounds like it would be a TCM type issue or computer related unless you've never maintenanced your TC, etc.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #4
Sounds like what happens when your transfer case engages in 4LO. Your turning radius being affected means it's likely that your front differential is actually working via the transfer case. I'd start there (i.e. make sure you're in regular drive without 4LO, etc). If that's not it, sounds like it would be a TCM type issue or computer related unless you've never maintenanced your TC, etc.
Its definitely not in 4lo, that would be obvious. I bought the truck at 54k miles, it has 58k now. There may not have been any maintenance done. I think when I get to work, dealership. I'll have my service guys do the diff, TC, and tranny fluid change. see if that fixes it.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #5
Still doing it, here is a video of the noise, any ideas? made an appointment to see what the dealer thinks and hopefully its covered under warranty.

Turn up your volume its kind of quiet but you can definitely here the grinding noise

 

·
Registered
Joined
·
340 Posts
i can't hear it. is it a clicking noise at full lock? mine had the same issue. i just rebuilt my front end and its all good now.
 

·
Registered
Joined
·
340 Posts
I'm not sure, but I'm thinking the spider gears did it in. I just replaced everything...
 
1 - 9 of 9 Posts
Top