Jeep Garage  - Jeep Forum banner
1 - 4 of 4 Posts

·
Registered
Grand Cherokee
Joined
·
326 Posts
Discussion Starter · #1 ·
My ipod works pretty good in the new jeep. A couple things though, ipod stays plugged in all the time and when I start the car the album art work does not show up, not does the 'tracks' button on the right side of the screen or the 'info' button. To get them to show up I have to push 'browse' then back out of that screen, then magically everything is there...same for everyone else? ipod classic btw.

So far only weird thing that has happened was today after getting back in the car and starting it up, the music slowed down on the artist I was listening to ipod also. Switched to a different playlist then back and the speed went back to normal. Per itunes my ipod is up to date, haven't tried it with my iphone plugged in yet, just over BT.
 

·
Registered
Joined
·
311 Posts
I've been having weird behavior with my iPhone as well... looks like the uconnect software doesn't work flawlessly with iPod/iPhones... it gets lost sometimes! With album cover and that kinda stuff... but I don't need to reconnect, it usually comes back after a while. Not sure if it gets messed up during initialization...
 

·
Registered
Joined
·
15 Posts
My ipod works pretty good in the new jeep. A couple things though, ipod stays plugged in all the time and when I start the car the album art work does not show up, not does the 'tracks' button on the right side of the screen or the 'info' button. To get them to show up I have to push 'browse' then back out of that screen, then magically everything is there...same for everyone else? ipod classic btw.
Make sure you press Media in the radio touch screen. I find that if I last listed to iPod, shut off Jeep and come back - the music will play but it's not actually selected on Media anymore. Once you hit Media all the tracks and album art etc come back (as well as shuffle). No need to browse.
 

·
Registered
Grand Cherokee
Joined
·
326 Posts
Discussion Starter · #4 ·
Make sure you press Media in the radio touch screen. I find that if I last listed to iPod, shut off Jeep and come back - the music will play but it's not actually selected on Media anymore. Once you hit Media all the tracks and album art etc come back (as well as shuffle). No need to browse.
I figured that out too. Annoying though, shouldn't have to do that.
 
1 - 4 of 4 Posts
Top