Jeep Garage  - Jeep Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
There is a alarm coming up in the bottom right corner that looks like a lightning figure. When car is cold or driving, Then the turbo cuts out.Spend lot off money but problem stil on.Any one that can help.

Andre.
 

·
Registered
Joined
·
989 Posts
The little lightning bolt signal is for the Electronic Throttle Control.

What has been checked? Anything replaced? Are there any codes being stored?

Could be as simple as a dying battery or as complicated as a failing swirl motor...
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
I was told it was the intake frirl actuater in the intake manifold. I did change that at great cost.I do have a new battery. then a sensor and harnass in the front diff was changed.. Then i was told it is because the car is over heating. The fan switch was changed. The latest is the gearbox is overheating. I have not done anything there. I dont have any fault codes.

Thanks for reply.
 

·
Banned
Joined
·
909 Posts
im guessing youre in a foreign country and there are probably not alot of jeep dealers but it sounds like you need to take it to a differant dealer
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
I am in South Africa. There is quite a number off dealers here but it seems nobody can find the fault.
 

·
Registered
Joined
·
989 Posts
I was told it was the intake frirl actuater in the intake manifold. I did change that at great cost.I do have a new battery. then a sensor and harnass in the front diff was changed.. Then i was told it is because the car is over heating. The fan switch was changed. The latest is the gearbox is overheating. I have not done anything there. I dont have any fault codes.

Thanks for reply.
Without any stored codes, they are likely going to have to hook it up to a computer so they can check the PCM conditions as the problem occurs.

I highly doubt it has anything to do with over heating, sensors in the diff, etc.

Without it storing a code, you are going to need a shop that is good at electrical trouble shooting...it sounds like the place you have taken it to in the past is simply changing out parts that they know how to replace!
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #8 ·
The fault is not sustained. It comes and goes.On cold start when it comes on and you switch off and on again its gone. It also happened a few times when driving in very hot conditions. When you stop and switch on its gone.i am seeing a gerage in Bloemfontein tomorow and hopes they can help.I had good references to them.
 

·
Registered
Joined
·
9 Posts
I had the same problem with my 07 CRD. After investigating swirl motor etc the problem turned out to be the EGR valve sticking. Many people will tell you that the EGR valve cannot be removed without the engine being lowered,i can tell you that this simply not the case. Yeah it took a while to get it out and my language was pretty colourful but i managed none the less. Whilst it was removed i fully cleaned and lubricated all the moving parts and the problem has never happened since.
 
1 - 10 of 10 Posts
Top