Jeep Garage  - Jeep Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
The battery on my 2018 Grand Cherokee completely died so I had to replace it. I did the work myself but now the AC/Heater has really low airflow. It worked perfectly fine before battery replacement but now no matter what flow setting I set it to (1-7) it feels like it’s at the lowest setting. The temperature and the setting (floor, dash, etc.) change but the flow doesn’t change at all. Everything else seems to be working fine only thing is the low airflow. Any idea what it could be? Did I accidentally mess with something? Stop/Start is equipped and now that I think about it I don’t recall it engaging since the new battery went in. Not sure if any of this information will help at all but any input on what could be going on is greatly appreciated!
 

· Registered
Joined
·
2,567 Posts
The battery on my 2018 Grand Cherokee completely died so I had to replace it. I did the work myself but now the AC/Heater has really low airflow. It worked perfectly fine before battery replacement but now no matter what flow setting I set it to (1-7) it feels like it’s at the lowest setting. The temperature and the setting (floor, dash, etc.) change but the flow doesn’t change at all. Everything else seems to be working fine only thing is the low airflow. Any idea what it could be? Did I accidentally mess with something? Stop/Start is equipped and now that I think about it I don’t recall it engaging since the new battery went in. Not sure if any of this information will help at all but any input on what could be going on is greatly appreciated!
Hey there.
If you don't find the answers you're looking for from the other forum members, we'd suggest a visit to the dealership. If you decide to go that route and need our support, send a private message or call 877-426-5337.

Kate
Jeep Cares
 

· Registered
2014 Summit 5.7 4wd 20" tires swapped to 18", added all skid plates
Joined
·
3,214 Posts
The battery on my 2018 Grand Cherokee completely died so I had to replace it. I did the work myself but now the AC/Heater has really low airflow. It worked perfectly fine before battery replacement but now no matter what flow setting I set it to (1-7) it feels like it’s at the lowest setting. The temperature and the setting (floor, dash, etc.) change but the flow doesn’t change at all. Everything else seems to be working fine only thing is the low airflow. Any idea what it could be? Did I accidentally mess with something? Stop/Start is equipped and now that I think about it I don’t recall it engaging since the new battery went in. Not sure if any of this information will help at all but any input on what could be going on is greatly appreciated!
I can't offer anything specific but when all else fails the no cost option is to disconnect the battery for an hour or two and see if that will reset the computers and get things working properly again.
 

· Registered
Joined
·
5,382 Posts
Did you replace both batteries or just the big one?
Is the blower issue only when Stop/Start shuts off the engine?
 
1 - 4 of 4 Posts
Top