Jeep Garage  - Jeep Forum banner
1 - 15 of 15 Posts

· Premium Member
WK2 Summit
Joined
·
156 Posts
Discussion Starter · #1 ·
Hey Guys-

I am perplexed and disappointed. Approx 2 weeks ago with only 2700miles I have been having issues with the Blind Spot Detection on my MY14 Jeep Grand Cherokee Summit.

It started with going off with the error message "Blind Spot Alert Unavailable" every other day to daily to hourly and now all the time. I brought to dealership after two visits with new mirrors and module, it still not working. It remains on all the time.

I have found one post on here about an astronomy zone however the dealership has NO idea what that is. They are sending a call to Chrysler to report the problem.

Yes, I have washed the truck many times which is pretty normal keeping my ride clean and garage kept.

Irritated. :mad:
 

· Registered
Joined
·
877 Posts
If your problem is the same as the one I had, one of the side mirror BSD triangles should light up and remain lit when the system faults.

The fix for mine was the replacement of a module in the driver's door.
 

· Registered
'15 GC High Altitude
Joined
·
308 Posts
Where are the actual sensors, anyway? Where do they emit from? Been wondering that.
 

· Registered
Joined
·
1,978 Posts
Where are the actual sensors, anyway? Where do they emit from? Been wondering that.
There is 1 on each side under the rear bumper fascia. I've noticed that sometimes a vehicle will be coming up fast in the lane on my left and they will brake quite suddenly, then after a minute or so, they then accelerate past. I've read where some radar detectors will give a warning and that would explain why I've noticed this occurring.
 

· Registered
Joined
·
172 Posts
I am having the exact same problem. I haven't bothered going to the dealer yet because I never use the feature but glad to know what the fix is so I can arrange for the part from my guys at Chrysler HQ before brining it in.
 

· Premium Member
WK2 Summit
Joined
·
156 Posts
Discussion Starter · #7 · (Edited)
I am having the exact same problem. I haven't bothered going to the dealer yet because I never use the feature but glad to know what the fix is so I can arrange for the part from my guys at Chrysler HQ before brining it in.
Replacing the mirrors or the module did not correct my problem. They have sent an inquiry to Chrysler. Hopefully I will have a resolution soon.
 

· Premium Member
WK2 Summit
Joined
·
156 Posts
Discussion Starter · #10 ·
Hey Guys-

I am perplexed and disappointed. Approx 2 weeks ago with only 2700miles I have been having issues with the Blind Spot Detection on my MY14 Jeep Grand Cherokee Summit.

It started with going off with the error message "Blind Spot Alert Unavailable" every other day to daily to hourly and now all the time. I brought to dealership after two visits with new mirrors and module, it still not working. It remains on all the time.

I have found one post on here about an astronomy zone however the dealership has NO idea what that is. They are sending a call to Chrysler to report the problem.

Yes, I have washed the truck many times which is pretty normal keeping my ride clean and garage kept.

Irritated. :mad:
Update


My service dept has not update or response from Chrysler and their START system. They sent another email. They feel my issue is unusual since replacing the module didn't work. Disappointed.
 

· Registered
Joined
·
2 Posts
I have a 2014 Jeep Grand Cherokee Overland, My blind spot monitoring system is not working either, had it in for service while I was out of Town because the MIL light was on also, was told the part was on back order. Brought it to my Dealership when I returned home. I was told the same thing. Part was on back order. Contacted Chrysler Customer Service and they had the parts within a week to "fix" both issues. Just had the car in for service today, The issue causing the MIL SEEMS to be fixed, however, the blind spot monitoring system message came on again on my way home. I contacted service but they said I will "have to set up another appointment. Has anyone had this issue and has it been resolved yet? This is one of the features that I purchased the Overland model for. I am upset that I am paying for a feature I can not rely on.
 

· Registered
Joined
·
2 Posts
2014 Overland with the very same issue. Started intermittently months ago and brought it in. They thought they had resolved the issue but it continued and now happens within a few minutes of starting the engine every time. In the shop as I write this. Hopefully gets resolved today
 

· Registered
Joined
·
2 Posts
The issue with my blind spot monitoring system was corrected but after numerous trips to my Dealership's service department and having to get Chrysler HQ involved! NO ONE at my dealership believed there was an issue because the error message was not on when they first started the car. Apparently, I had nothing better to do than bring my relatively new vehicle in for service for an imaginary problem...that's how they made me feel. FINALLY, it was fixed by them replacing BOTH modules. I still am not 100% sure they EVER replaced the one side in the first place. I told the Service Department that I read that the mirror assemblies needed replaced as well, but Chrysler HQ wanted them to replace just the modules first, and fortunately, that resolved my issue, but it was VERY ANNOYING because as I stated, this was one of the reasons I bought the Overland, I use this feature quite a lot because I travel on Interstates a good deal of the time. They have been working fine ever since they replaced the part, but recently, the triangle on the right side will beep and light even if there is not a car around. I am not sure what it is sensing and I hope there is not another issue beginning with it! This was my first Jeep and I have to admit, I have had more recalls and minor problems with it in the almost 2 years that I have owned it than any other vehicle I have owned! Jeep did send a customer appreciation coupon for either service or parts because they are aware of the aggravation this is causing, but I was advised not to purchase another brand I was seriously considering because of "reliability issues" but I am experiencing it with Jeep which I thought was a solid brand. I guess anything mechanical/electrical can have issues!! Good luck. I hope anyone experiencing this issue gets it resolved because I know how annoying it is!
 

· Registered
Joined
·
2 Posts
Have been having the same issue with my 2014 Overland. The first time I brought it in they said that it was fixed and the problem reoccurred. Went back last week and they replaced the module and it has been working since. Fingers crossed.
 

· Registered
Joined
·
5 Posts
cto521, I feel ya.
My biggest issue is my Jeep is out of warranty and all these problems are happening so its costing $$ out of my pocket.

-Those BSM modules are around $1000. Well looks like I'm disabling blind spot monitoring until the Jeep is crushed.
-Got a P0480 but the fan works fine?!!:confused:
-Jeep has issues starting up even after installing the external fuel pump relay.:confused:

I traded in my 2009 RT Nitro for a more reliable automobile once my daughter came along. Boy am I kicking myself now. I'll never buy a Chrysler product again.

This Jeep it's the biggest heap of S&%T I've ever bought.:mad:
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top