Jeep Garage  - Jeep Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·


This is how my dash looked a few days ago, after starting the car and leaving the key in the ON position several times. It also would randomly turn the headlights on and off no matter what setting they were on, and the power seemed to fluctuate as well (because the radio would flutter on and off), and a non-responsive tachometer. Then I went back to class before dealing with it any further, and when I came out it only had a check engine light on. I took it down to autozone to have the code read where the tech told me that they couldn't pull anything and sent me to a shop down the street. Unfortunately they had closed already for the day but the check engine light went away on the drive and all seemed good so I brought her home.

It drove around fine with absolutely no problems, sounded fine, all the electrical worked. Two nights later, I went out to check on things and it all seemed fine still. The next morning I came out and went to start it and it was 110% dead. No starter sound, no lights anywhere, couldnt even open a window or move the seats. She sat like that for a day because I was preoccupied with other work, and today I had a friend jump it. Took about 10-15 minutes for it to get enough of a charge to start. I left it running idle for a half an hour or so to try to bring the battery back up to some juice before leaving it overnight again.

But while it was idling, I noticed a few issues. The minor ones being that the compass was not reading the correct direction (and seemed to change randomly whenever the car was turned off/on), and the temperature reading 77 degrees while I'm in upstate NY with 28 degree weather currently... And then the major flaw being the tach bouncing between 0 and 1000rpm, without the engine changing speed at all (she was humming just fine at normal idle speed), and no tach reaction to touching the gas pedal (although the car would rev up as per usual). Also while just idling, the airbag light would periodically turn on/off, accompanied by a ding, or sometimes the ding but no warning lights, or sometimes all the warning lights, and sometimes the EVIC would say "check gauges, check transmission, check 4wd sys, etc.." basically every warning that it could.

Video of Tach Bouncing

Any help with even a remote idea of how to tackle this would be greatly appreciated. :ghost:
 

·
Registered
Joined
·
989 Posts
How old is your battery?

These Jeeps do some crazy things as the battery voltage drops (including throwing all sorts of strange error messages).

With the battery dying so soon after, I would suspect your battery is on the way out and all should go back to normal once it has been replaced.
 

·
natural born world shaker
Joined
·
2,692 Posts
How old is your battery?

These Jeeps do some crazy things as the battery voltage drops (including throwing all sorts of strange error messages).

With the battery dying so soon after, I would suspect your battery is on the way out and all should go back to normal once it has been replaced.
x2

this has happened to me twice and it was the battery both times.
 

·
Registered
Joined
·
49 Posts
x 5 on the battery.

Happened to me this weekend. Jeep kept turning on its own lights, turned ignition on and interior fan and wipers were on full, but the switches were off and the lights would turn on by twisting the stalk, but not turn off. Also had recent issues such as being unable to unlock car , and heated seats wouldn't switch on until a few minutes of driving.

New battery seems have sorted it all out, and now I notice the engine turns over quicker too, and starts first time, wheres at 32%F I sometimes had to try 3 times to start the CRD.

Made a believer out of me that an off battery would cause this - change it :)
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Just put in a new battery and all the same errors are still flashing, tach is bouncing, lights flick on and off. I tested the battery with a voltmeter and it read out at 14.3V while running idle and 12.4V just sitting, so I know the alternator's fine. I just unhooked the battery for the night so as not to accidentally drain it. And I guess I'll have to call the dealer tomorrow.
 

·
Registered
Joined
·
49 Posts
Thats a shame, still it probably needed changing and you probably did it cheaper than the main dealer. Have you ever changed the ignition switch?
 

·
Registered
Jeep Grand Cherokee
Joined
·
324 Posts
Any updates on this? I have had the lights on my dash do nearly the same thing yesterday... And by the end of the day everything went back to normal.
 

·
Registered
2005 Grand Cherokee
Joined
·
1,019 Posts
Any updates on this? I have had the lights on my dash do nearly the same thing yesterday... And by the end of the day everything went back to normal.
If it's not the battery, it's probably the the ignition switch or the multifunction stalk. For me, it was the multifunction stalk, which is of course the more expensive part at $110ish vs the ignition switch at $20ish.

Had all those same symptoms which scared the piss out of me one night while driving home on a dark and curvy road. It happened intermittently after that, but I never had an issue cranking. Due to that symptom, I'd start with the ignition switch.
 

·
Registered
Jeep Grand Cherokee
Joined
·
324 Posts
Haven't had those symptoms since I posted. But the next day my key fob started to go dead. I just put in a new battery. $3. I'll post again if it happens again.
 
1 - 11 of 11 Posts
Top