Jeep Garage  - Jeep Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello,
I have a Jeep Grand Cherokee WJ 3.1 TD with what I belive 42RE transmission. I have a problem with my transmission, it shifts nice first three gears. The problem is with overdrive which only engages when its hot (it engages mostly in summer when outside temps are high but only after driving the car at least 30 min or it engages much faster if I am towing a trailer). When it starts shifting to overdrive it works perfect and stays in it for as long as it is needed. Overdrive button works, O/D light is not on when no overdrive. Downshifts are also ok. I did change oil and filter, governor pressure sensor and solenoid,coolant temperature sensor, still no change. No codes. If somebody has an idea of what the heck is happening :confused: would be greatly appreciated. Sorry for bad English I am from Europe .
 

·
Registered
Joined
·
4 Posts
hi
where are you from?
and you need pass in Apresentation tread.

I have a Wj 3.1 in Europe. This model only in Europe, Russia and South America.
Your Wj have a 44RE Transmission, you can confirm that with vin code. google it.
Verify if you use oil ATF+4 or Multi ATF, and need have correct level oil.

Best Regards
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Hello,
Thank you for reply Wabatuckian and Tryder. Oil and filter was changed with atf 4+ rated oil and is correct level. Yes after transmission warms up it starts shifting to overdrive nice and smooth and overdrive button works. Sometimes it happens that it starts from second gear, but that is not often,usually is fine.
 

·
Registered
Joined
·
4 Posts
hi again.
My 3.1 Td have 317.000 KM, i change only 2 sensor (pressure and velocity), change filter and oil. and run fine, change shift its good. Try see if any conector have insue. And have u try disconect batery to clear safe mode?

One more where are you JeepWj_3.1? im in Europe too and my english is bad too :)
 

·
Registered
Joined
·
4 Posts
Discussion Starter #9
hi,
Still no progress with overdrive,will try with disconnecting battery but dont have high hopes... I also had some problems with engine because mechanic changed some old leaking oil pipes and he got something wrong with vacuum...Tryder I am from Croatia and you ?
 

·
Registered
Joined
·
128 Posts
JeepWJ_3.1,

I was studying TCM operation on these and thought of your post.

When the transmission is colder than 40 degrees F (about 4.4 deg C) the torque converter clutch won't lock.

Therefore, when the vehicle is cold, the revs are higher and makes it appear as if the OD isn't working, when in fact it is.

So, your torque converter isn't locking when the transmission is cold, and that's normal :thumbsup:

Regards,
Josh
 
1 - 10 of 10 Posts
Top