Jeep Garage  - Jeep Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
2,206 Posts
Discussion Starter · #1 · (Edited)
Went to leave after work today and right when I started the Jeep I immediately got the MIL. Did the key dance and got P0152 - O2 Sensor 2/1 Circuit High.

I've got the negative battery cable off it right now for about 10 minutes to try and reset everything. If it comes back, guess I'll buy a new O2 sensor.
 

·
Registered
Joined
·
14,382 Posts
Sorry to hear. Good luck...
 

·
Registered
Jeep SRT8
Joined
·
6,440 Posts
I remember you saying that you were running 93 octane on the 91 Superchips tune... if that's true, you should run 91 octane for the tune or else you'll continue to get the code.
 

·
Registered
Joined
·
2,206 Posts
Discussion Starter · #5 ·
I remember you saying that you were running 93 octane on the 91 Superchips tune... if that's true, you should run 91 octane for the tune or else you'll continue to get the code.
91 octane is not offered around here. it is 87/89/93.

I had been running 93 on the 91 tune for probably 2 weeks/1000ish miles before this happened - I think it would have popped up earlier if running 93 was a problem?
 

·
Registered
Jeep SRT8
Joined
·
6,440 Posts
You could be running rich.. either that or your sensor took a dump.
 

·
Registered
Joined
·
2,206 Posts
Discussion Starter · #7 ·
We'll see.. the MIL went away after disconnecting the battery for a little while. The truck has been running fine.
 

·
Long Live the Grey Ghosts
Joined
·
13,493 Posts
manual says:
When Monitored:
O2 Sensor Heater Temperature is greater than 496° C (925° F) and battery voltage greater than 10.99 volts.

Set Condition:
The Oxygen Sensor voltage is above 3.9 volts for 30 seconds. Two Trip Fault. Three good trips to turn off the MIL.


Possible Causes

(K43) O2 2/1 SIGNAL CIRCUIT SHORTED TO BATTERY VOLTAGE

(K902) O2 RETURN UPSTREAM CIRCUIT SHORTED TO BATTERY VOLTAGE

(K43) O2 2/1 SIGNAL CIRCUIT OPEN

(K902) O2 RETURN UPSTREAM CIRCUIT OPEN

O2 SENSOR

PCM
_____________

i would make sure you didnt melt a wire down there before going to much further.
 

·
Registered
Joined
·
2,206 Posts
Discussion Starter · #11 ·
manual says:
When Monitored:
O2 Sensor Heater Temperature is greater than 496° C (925° F) and battery voltage greater than 10.99 volts.

Set Condition:
The Oxygen Sensor voltage is above 3.9 volts for 30 seconds. Two Trip Fault. Three good trips to turn off the MIL.


Possible Causes

(K43) O2 2/1 SIGNAL CIRCUIT SHORTED TO BATTERY VOLTAGE

(K902) O2 RETURN UPSTREAM CIRCUIT SHORTED TO BATTERY VOLTAGE

(K43) O2 2/1 SIGNAL CIRCUIT OPEN

(K902) O2 RETURN UPSTREAM CIRCUIT OPEN

O2 SENSOR

PCM
_____________

i would make sure you didnt melt a wire down there before going to much further.
The code hasn't been back since I cleared it, and the truck is driving completely normal.
 

·
Registered
Joined
·
2,206 Posts
Discussion Starter · #12 ·
Well one week later and a trip to NC and back and the code hasn't come back. Guess it was just a one time fluke deal.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top