Jeep Garage  - Jeep Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Long story short I showed up earlier for work and took a nap(about an hour or so) in the car.I kept the car running so I can enjoy the AC.
After I woke up I noticed the 'part time" light on the dash was on and it shouldn't because I didn't mess with the gears at all. That kinda freaked me out so I moved the gear shifter to part time and the light went off.
Really freaked at that point I put it in 4WD full time and drove around the block. No issues what so ever. I put it back in 2WD and it was OK for a few seconds and then the light came on again. I drove it again and there is nothing different about it....
Now I am sitting at work scratching my head wondering is it safe to drive, what is causing that weird behavior and should I drive it in 4WD full time till I figure out what's wrong with it.
I have a 04 WJ(I6 engine) with the 42RE tranny I believe.
Any and all help and suggestions are welcome. really have no idea what is wrong with it.
Checked the tranny fluid and it's level is OK.
I didn't do anything different other than letting it idle for like 75 min with the AC on.
 

·
The beast from Brazil
Joined
·
8,285 Posts
When i'm not wrong the part time light is switched by a switch on the T-case. Most probably this switch is faulty, but you could first try to clean the connector pins and check the wire for any chaving.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
Would I be able to reach the connector from under the car or is there something else that I need to take off?
 

·
The beast from Brazil
Joined
·
8,285 Posts
No experience on this myself, but the sensor ( i previously stated switch, but it is a position sensor) is just mounted next to the selector lever on the upper side of the T case. Not sure if you can easily access it.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #5
Thank you. Also do you think that heat could cause this? I started the car again after cooling down for an hour and the light is off....
 

·
The beast from Brazil
Joined
·
8,285 Posts
Heat can play a rol. Just wait and see how it will behave the next days.
 

·
Registered
2000 Patriot Blue WJ
Joined
·
56 Posts
I too have had intermittent 'part time' light show up often after switching back into 2wd from 4 full time. I usually pull onto my gravel drive and give a little gas to spin the rear tires to ensure its in 2wd. The sensor is a little odd sometikes, ive never looked into it. As long as I'm back in 2wd I can rest assured. The shifter is the key. Give firm shift up to 2wd and find a lil gravel or dirt. My PT light will go off a day or 2 later. Should be no worries bud.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #9
I am sure it was never in "part time" because I was no where near that shifter lol. Anyway it dissapeared once the car cooled off. Won't sweat it too much at this point:)
Thanks for all the help guys.

Sent from my Kindle Fire using Tapatalk 2
 

·
Registered
2004 Jeep Grand Cherokee
Joined
·
2 Posts
I am sure it was never in "part time" because I was no where near that shifter lol. Anyway it dissapeared once the car cooled off. Won't sweat it too much at this point:)
Thanks for all the help guys.

Sent from my Kindle Fire using Tapatalk 2
 

·
Registered
2004 Jeep Grand Cherokee
Joined
·
2 Posts
I have had that same problem. It only happens when the Jeep gets hot. (usually after being stuck at a long light in the summer or parked and idling in the warmer weather) Let me know if you figure it out.
 
1 - 11 of 11 Posts
Top