Jeep Garage  - Jeep Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello, my wife drives a 2018 Jeep Grand Cherokee overland with the Quadra-lift. Purchased new. Now has 55,000 miles.

It has developed a issue with the Quadra-lift system. I’m afraid taking it to a dealer will result in a automatic compressor replacement which I’m unsure it needs.

When you start it you can transition from any ride height without problem. However once you take off in the first few minutes of driving it will pop up with “service air suspension immediately “ and stop working. (This seems to happen most often when it attempts to go into area mode). Once you stop the vehicle and turn it off everything comes right back. You can again raise and lower the Jeep without issue until it faults out again.

No sag or compressor continually running. Everything seems function great until it faults.

Would anyone have any suggestions as to what direction to look at?

Thanks in advance!
 

·
Registered
2015 WK2 Overland
Joined
·
2,116 Posts
You need to see what code is being tripped when this happens. It sounds like it could be a bad ride height sensor.
 

·
Registered
Joined
·
204 Posts
This will sound weird, but is the coolant temp
Gauge reading zero? I was having this warning and service electronic throttle warning. My temp gauge was not registering anything when it was a warm re-start. Replaced the coolant temp sensor and the problems went away.
 

·
Registered
97 XJ,99Mustang GT C
Joined
·
460 Posts
Hello, my wife drives a 2018 Jeep Grand Cherokee overland with the Quadra-lift. Purchased new. Now has 55,000 miles.

It has developed a issue with the Quadra-lift system. I’m afraid taking it to a dealer will result in a automatic compressor replacement which I’m unsure it needs.

When you start it you can transition from any ride height without problem. However once you take off in the first few minutes of driving it will pop up with “service air suspension immediately “ and stop working. (This seems to happen most often when it attempts to go into area mode). Once you stop the vehicle and turn it off everything comes right back. You can again raise and lower the Jeep without issue until it faults out again.

No sag or compressor continually running. Everything seems function great until it faults.

Would anyone have any suggestions as to what direction to
 
1 - 5 of 5 Posts
Top