Jeep Garage  - Jeep Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2014 Jeep Grand Cherokee Overland - took delivery in April 2013. A couple of weeks ago I upgraded my RA4 to 13.19.0. All seemed good after the upgrade - several annoying problems fixed. About 3 days ago, I noticed that the signal strength indicator on the apps button was spending a lot of time in 1X instead of 3G. I had never seen it in 1X before. Over the last 2 days, it has stayed in 1X, never going to 3G. Obviously, that isn't right.

In addition, today the "Vehicle Telephone Needs Service" message has popped up twice - also the first time I have seen this message. This message does not pop up every time I start the car, but has come up twice today.

Has anyone else experienced similar issues, and if so have you been able to resolve them?
 

·
Premium Member
Joined
·
4,989 Posts
I have a 2014 Jeep Grand Cherokee Overland - took delivery in April 2013. A couple of weeks ago I upgraded my RA4 to 13.19.0. All seemed good after the upgrade - several annoying problems fixed. About 3 days ago, I noticed that the signal strength indicator on the apps button was spending a lot of time in 1X instead of 3G. I had never seen it in 1X before. Over the last 2 days, it has stayed in 1X, never going to 3G. Obviously, that isn't right.

In addition, today the "Vehicle Telephone Needs Service" message has popped up twice - also the first time I have seen this message. This message does not pop up every time I start the car, but has come up twice today.

Has anyone else experienced similar issues, and if so have you been able to resolve them?
The two items are related. 1x is an old network which the system can fall over too. It is possible but unlikely this is related to a coverage problem.

You can try reloading the 13.19.0 as this will attempt a software reload to the wireless card. The problem is not caused by the update specifically but possibly an actual issues with the wireless card from day one.
 

·
Premium Member
Joined
·
4,989 Posts
Yes, There is a Star Case but it is vauge on the Phone Service error. make sure you let them know you are seeing that message repeatedly during normal use, not just at startup. This is important.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top