Jeep Garage  - Jeep Forum banner

1 - 2 of 2 Posts

·
Registered
2008 WK v6
Joined
·
1 Posts
Discussion Starter #1
I can’t figure out what the issue is so any help would be greatly appreciated.

I have a 2013 grand Cherokee 3.6. When I start up it runs perfectly fine. The issue is when I put into reverse the engine starts to shake as if it will stall. I quickly have to take my foot off the brake so it goes into reverse quickly or else it’ll shake/stall (or almost stall) if my foot is kept on the brake.

Also at a red light it will slightly shake. This shake happens until the engine is completely warmed up and it’ll seem to operate normally after that.

Any ideas? It stalled in reverse today and I’m fed up.
 

·
Registered
Joined
·
1,944 Posts
I can’t figure out what the issue is so any help would be greatly appreciated.

I have a 2013 grand Cherokee 3.6. When I start up it runs perfectly fine. The issue is when I put into reverse the engine starts to shake as if it will stall. I quickly have to take my foot off the brake so it goes into reverse quickly or else it’ll shake/stall (or almost stall) if my foot is kept on the brake.

Also at a red light it will slightly shake. This shake happens until the engine is completely warmed up and it’ll seem to operate normally after that.

Any ideas? It stalled in reverse today and I’m fed up.
Hi @alloutmk23

Sorry to hear about the concerns you're experiencing. Are you currently working with a Jeep dealer to get this addressed? I can certainly look into this further if you'd like. Please feel free to send our JeepCares team a private message with your current mileage & VIN if you'd like additional assistance!

Courtney
Jeep Cares
 
1 - 2 of 2 Posts
Top