Jeep Garage  - Jeep Forum banner
1 - 20 of 29 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter · #1 ·
Hey guys what's up ? Well here is what I've done , Friday I put 8oz of seam foam in my oil , yesterday I put in the intake hose and went through the steps and it still drove fine after the smoke show , then I installed my new Taylor shorties ,I tried to start it and it took awhile for it to start, once driving I did a quick WOT run and it started chugging like it was running out of fuel . I don't know what could be causing this . After the shorties should I have disconnected the battery for a reset ? Any help would be greatly appreciated !

Thanks, Chris
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #3 ·
Yeah wires only go on one way with the shorty wire setup , reset battery now and take for a blast down the highway and see what happens lol
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #5 ·
This doesn't look like the one on my car , any ideas ? Mine doesn't look like it has screws holding it down

Electronics Technology Electronic device
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #8 ·
Yeah it is the map sensor that I bought but the one on my jeep doesn't look like that
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #14 ·
Nope I work at a dealer , get whole sale prices , paid 18 bux for it lol
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #16 ·
yeah it works out good sometimes ! After doing some research I think the new MAP sensor has to be modified to fit ! WTF ? I read that the mounting tabs may have to be cut on the new sensor and there may be one on the intake that needs to be trimmed also lol and it doesnt look to be much room where the MAP is located ! I also bought new plugs too figuring they may be fouled after running the sea foam thru this weekend . I hope one of these 2 things work ! I could barely get it to turn over this morning !
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #17 ·
Installed new map sensor and its still the same any ideas why my sea foam experience has been terrible ???
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #21 ·
put stock wires on and still ran the same :( not even fun to drive anymore and i just got it! I guess that means I will have to drive ol'faithful (5.9 jeep)
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #23 ·
I'VE been driving it since i think sunday like this . The day I sea foamed it after I let it sit for 20 mins with engine off to let sea foam soak in , i started it up and it smoked like a mother Fer,after letting it idle a few mins in my drive way I took it for a ride , drove it in a lower gear floored it around town blowing smoke everywhere lol , then smoke cleared up and it was running pissa ! the next morning i went out to start it and it wouldnt start just kept turning over but not starting, after like 5 mins it finally started with me giving it a little gas as I was turning the key. At low speeds it seems ok(seems like mds kicks in more though at low speeds then it used too) but when u gas it it falls on its face .....took it on the highway to clear it out and still not right,i dont know if this makes sense but it seems like the rpms race when i floor it but it sputters and doesnt launch ......so i don't know if i fouled the plugs some where in between? EGR clogged now maybe ??? I'm puzzled! before the seafoam it ran good and shifted good so i don't know
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #24 ·
another way to explain it is that when i floor it off the line it sounds like i'm hitting the rev limiter, wicked stupid
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #26 ·
no lights or codes, idles normal ,sometimes when i come to a stop they will drop a little. revs ok in park/neutral seems to do it under load conditions .
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #30 ·
Yeah I can only imagine how hard they are to keep clean lol !

No haven't checked plugs yet , that this weekends plan , I think they are the original plugs so at 80k they are due anyways !
 
1 - 20 of 29 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top