Jeep Garage  - Jeep Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I'm having an odd issue and was hoping someone can help. I bought a used 2017 JGC Trailhawk.

When i turn off the Jeep after driving it, the infotainment screen stays on sometimes, but others times it turns off immediately. What's happening? I can't seem to control it and seems random. The settings is set for a screen off delay (I think that's the control for that).
I would appreciate any help.

thanks
KD
 

·
Registered
18 WK2 Trailhawk
Joined
·
488 Posts
If you have the screen delay set and you open the door that will usually cause it to go off. Sometimes if you were on the phone connected to bluetooth and you send it to the actual phone itself sometimes the display will stay on for a bit even after you open the door. These are based on the Jeep ignition off and not running. HTH
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
I do have the screen delay set. I tested it and even with the door closed, when i turn off the car, after driving, the screen will turn off immediately. Sometimes it stays on but not all the time.
I tried having my foot on the brakes and off as well, still seems random.

I haven't paired any phone to the Jeep yet.

Anyone else have other thoughts?
 

·
Registered
Joined
·
355 Posts
On all 3 of my GCs the screen stays on for the amount of time set in the delay setting if I turn the engine off and sit there listing to something on the radio. But if I open the door it goes off immediately.
 

·
Registered
Joined
·
1,595 Posts
I do have the screen delay set. I tested it and even with the door closed, when i turn off the car, after driving, the screen will turn off immediately. Sometimes it stays on but not all the time.
I tried having my foot on the brakes and off as well, still seems random.

I haven't paired any phone to the Jeep yet.

Anyone else have other thoughts?
Hello JKD,
We are certainly sorry to hear about your recent concern. Given that we are not technically trained, we do rely on our dealers to be our eyes and ears in the field. Keeping this in mind, if you are unable to determine the cause of this with the assistance of fellow forum members, I suggest connecting with your certified dealer as they are in the best position to assist. If you decide to go this route, please know that we are available via private message if you are in need of any assistance with that process.
Laura
JeepCares
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
Thanks @JeepCares, but i think i fixed it.
I updated the Uconnect to the latest software then refreshed the siriusxm subscription (for some reason i got unsubscribed) and now it seems to be working properly.

before the fix, the strangest thing was that my power windows was working after i shut off the engine, it was just the infotainment screen that turned off.

Anyways, I think it's solved. thanks everyone!
 
1 - 7 of 7 Posts
Top