Jeep Garage  - Jeep Forum banner

1 - 3 of 3 Posts

·
Registered
2011 Laredo X
Joined
·
7 Posts
Discussion Starter #1
I have a 2011 Jeep Grand Cherokee with 120,000 miles. 2 weeks sgo i had an issue one morning going up a hill where my Service 4WD light and ABS light came on and my car would not accelerate. I turned car off and restarted and it was fine. I took to dealer and when they read the codes they said there was a stored Code saying my jeep would not shift out of 2nd. They kept my jeep for 3 days and recommended i have a transmission tech look at it but wait time was over 3 weeks. Drive Jeep for a week without issue and then today in 2 separate instances i had the same issue. Anybody have a similar situation? Any advice appreciated.
 

·
Registered
Joined
·
1,537 Posts
I have a 2011 Jeep Grand Cherokee with 120,000 miles. 2 weeks sgo i had an issue one morning going up a hill where my Service 4WD light and ABS light came on and my car would not accelerate. I turned car off and restarted and it was fine. I took to dealer and when they read the codes they said there was a stored Code saying my jeep would not shift out of 2nd. They kept my jeep for 3 days and recommended i have a transmission tech look at it but wait time was over 3 weeks. Drive Jeep for a week without issue and then today in 2 separate instances i had the same issue. Anybody have a similar situation? Any advice appreciated.
Hi howard,
We're sorry to hear about this. Feel free to send us a PM. We'd be happy to connect you with a Case Specialist to work with you and your dealer.
Alex
JeepCares
 

·
Registered
Grand Cherokee
Joined
·
2,819 Posts
I have a 2011 Jeep Grand Cherokee with 120,000 miles. 2 weeks sgo i had an issue one morning going up a hill where my Service 4WD light and ABS light came on and my car would not accelerate. I turned car off and restarted and it was fine. I took to dealer and when they read the codes they said there was a stored Code saying my jeep would not shift out of 2nd. They kept my jeep for 3 days and recommended i have a transmission tech look at it but wait time was over 3 weeks. Drive Jeep for a week without issue and then today in 2 separate instances i had the same issue. Anybody have a similar situation? Any advice appreciated.
You need to read the Manufacturer Extended Fault Codes to get an idea what the problem is. A cheap OBDII scanner does not read the Manufacturer Extended Codes. You can get the FCADiag pretty cheap, read one of the threads about it on this forum.... ....otherwise you have to take it to a Dealer or Independent Shop that has the tools to read Manufacturer extended codes....

It could be as simple as a bad wheel speed sensor or as complex as a bad transfer case or ABS module.....
 
1 - 3 of 3 Posts
Top