Jeep Garage  - Jeep Forum banner
1 - 10 of 10 Posts

· Registered
Joined
·
103 Posts
Discussion Starter · #1 ·
We have a problem with our 2005 Grand Cherokee CRD 3.0L which has 65,000 miles on the clock. It only happens if the Jeep has been standing for awhile and when I have to reverse out and turn the steering wheel and this is when it occurs.
It also happens if moving forward and turning from cold. On hard lock it sounds almost like a grinding noise and you get a vibration through the steering wheel. No issue once it is in a straight line and done 2 - 3 miles. Any ideas please? Thanks.
 

· Registered
Joined
·
1,511 Posts
[No message]
 

· Registered
Joined
·
1,511 Posts
Tried to post above and somehow didn't. Anyway, your power steering pump is going out if it does that at full lock. Common problem with WK, and I did mine at 75k.
 

· Registered
Joined
·
103 Posts
Discussion Starter · #6 ·
Strangely enough the problem has disappeared? The first time it start occurring was after a long trip towing a 1800kg trailer. After a few days it was hardly noticeable.
On our return with the same trailer, it occurred for a few days afterwards and has now disappeared?
 

· Registered
Joined
·
24 Posts
I do agree with dmsfun about the power steering, mine was replaced around 60,000. Do you ever notice a whining noise while turning the wheels in your driveway? Now that you've mentioned towing, when is the last time you serviced the diff's and trans?
 

· Registered
Joined
·
103 Posts
Discussion Starter · #8 ·
We bought the vehicle last September with 60,000 miles on the clock. Although it has service stamps in it, we suspect that there is a possible the service was only oil changes etc and not a full service at 50,000 miles.
We have since found out that the previous owner had a leaking right shock absorber, but they only changed the one and not the pair. I think I will look at getting the diffs and transmission fluids changed ASAP.
 

· Registered
Joined
·
1,511 Posts
The symptoms will come and go, and are signs that you need to replace the power steering pump. Makes sense to also replace the serpentine belt at this time. Do it now before it fails completely and you get stranded.
 

· Registered
Joined
·
127 Posts
Hey you've probably fixed the problem by now. U got the skid and abs lights lol....but anyway, had the same problem. Had a shudder at full lock, didn't happen all the time. I also had a slight clunk only in reverse rolling..... Ended up being the LR speed sensor. Lights didnt come one until the sensor fully failed.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top