Jeep Garage  - Jeep Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Just bought a new 2020 Overland, replacing a 2015 Limited. One of my favorite Uconnect features is the Siriusxm favorite artist feature- being able to set artists and songs and be alerted if they are playing on any Siriusxm channel. Have been using it every day for over 5 years on my Limited.

Have had my Overland for about a week, and am sometimes seeing some very weird stuff with the favorites function-

Sometimes it just doesn't work at all. Even when there are some of my favorite artists playing, I get no alert and when going browse>favorites, screen says "there are no favorites playing" (even though there are)

Sometimes I get the favorites alert, but it only stays up for a second or two and disappears.

But then other times it works just fine.

No rhyme or reason. And all of my settings are correct.

I did some googling and did find some others reporting some of the same things over the past couple of years, but most of the posts were from other Chrysler brands, not Jeep GC

Anyone seeing anything similar?? Any ideas?? Sounds stupid, but this is one of my favorite things in the whole Uconnect system- will be so disappointing if it doesn't start working correctly.....
 

·
Registered
Joined
·
9 Posts
Discussion Starter #2
So just to follow up- the favorites feature is definitely screwed up for us. We get the visual and audio alert, but it only stays up for about 2 seconds, then disappears. Then, even when we have favorites playing on several channels, if you go to BROWSE>FAVORITES, the screen says "no favorites are playing"

Completely frustrating

Anyone else have this happen?? Any thoughts would be much appreciated....
 

·
Registered
Joined
·
341 Posts
So just to follow up- the favorites feature is definitely screwed up for us. We get the visual and audio alert, but it only stays up for about 2 seconds, then disappears. Then, even when we have favorites playing on several channels, if you go to BROWSE>FAVORITES, the screen says "no favorites are playing"

Completely frustrating

Anyone else have this happen?? Any thoughts would be much appreciated....
I have exact same issue with me on my 2018 SRT. Problem started few months after I bought the jeep back in 2018. Dealer tried few things and finally changed the radio. Was fine for about two years. then GPS started making problems showing I am in middle in lake Michigan. Dealer tried to update the software and completely froze the radio. Changed the radio again. Was fine for about a month and last week I started having same issue with Favorites. They are looking into it again, but most likely will be changing the radio again.... I agree with you. This is my favorite future and since we pay for XM radio we should be able to use it. Talk to you dealer. Most likely they need to replace your radio
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
I have exact same issue with me on my 2018 SRT. Problem started few months after I bought the jeep back in 2018. Dealer tried few things and finally changed the radio. Was fine for about two years. then GPS started making problems showing I am in middle in lake Michigan. Dealer tried to update the software and completely froze the radio. Changed the radio again. Was fine for about a month and last week I started having same issue with Favorites. They are looking into it again, but most likely will be changing the radio again.... I agree with you. This is my favorite future and since we pay for XM radio we should be able to use it. Talk to you dealer. Most likely they need to replace your radio
Mine is still not working. But I will say that as much as I love this feature, there is no way I am doing the major repair of replacing my radio for it as long as everything else works fine.

But- i have been doing a lot of research on this and I have found a ton of others Jeep owners on other forums ( many different brands, not just GC) who are having the exact same problem. So I don't think there is anything wrong with our radios or specific to our cars. With it happening to so many others, the EXACT same thing- (There is a pretty long thread on it on one of the Jeep Wrangler forums)

It HAS to be an issue on the Sirius/Uconnect side.

I have heard from several others who have gone to the trouble of taking car to the dealer for service and not a single one had any success.

Some have reported being told by Uconnect that they are aware of it and some sort of over the air fix would be coming at some point. I'll believe it when I see it, but I feel like that is the only thing that is going to fix this- not getting any kind of repair or radio replacement.

Hopefully the fix will come soon........
 

·
Registered
Joined
·
341 Posts
Mine is still not working. But I will say that as much as I love this feature, there is no way I am doing the major repair of replacing my radio for it as long as everything else works fine.

But- i have been doing a lot of research on this and I have found a ton of others Jeep owners on other forums ( many different brands, not just GC) who are having the exact same problem. So I don't think there is anything wrong with our radios or specific to our cars. With it happening to so many others, the EXACT same thing- (There is a pretty long thread on it on one of the Jeep Wrangler forums)

It HAS to be an issue on the Sirius/Uconnect side.

I have heard from several others who have gone to the trouble of taking car to the dealer for service and not a single one had any success.

Some have reported being told by Uconnect that they are aware of it and some sort of over the air fix would be coming at some point. I'll believe it when I see it, but I feel like that is the only thing that is going to fix this- not getting any kind of repair or radio replacement.

Hopefully the fix will come soon........
I agree that is no fun to go to the dealer. I think only part they replaced was the screen. After they did it I had to peel of protective plastic from the screen. All other settings were still the same. I just lost my XM favorites. After they changed the radio everything worked fine for over two years until the GPS broke and I had to get new radio to fix my navigation. New radio worked for a month until froze while I was driving on the freeway. After I restarted the Jeep twice everything came back normal except XM favorites issue. My service manager was out last week. I will talk to him tomorrow or Tuesday and will see what he has to offer. If he wants to swap the radio again I will probably do it. Only bad think is that I have to re-active my subscription with the new radio and this is $15.00 fee.
 

·
Registered
Joined
·
1,901 Posts
So just to follow up- the favorites feature is definitely screwed up for us. We get the visual and audio alert, but it only stays up for about 2 seconds, then disappears. Then, even when we have favorites playing on several channels, if you go to BROWSE>FAVORITES, the screen says "no favorites are playing"

Completely frustrating

Anyone else have this happen?? Any thoughts would be much appreciated....
We're sorry to hear that you are experiencing this concern. If you would like any additional assistance, our team is always available via private message!

Alison
JeepCares
 

·
Registered
Joined
·
1,901 Posts
Mine is still not working. But I will say that as much as I love this feature, there is no way I am doing the major repair of replacing my radio for it as long as everything else works fine.

But- i have been doing a lot of research on this and I have found a ton of others Jeep owners on other forums ( many different brands, not just GC) who are having the exact same problem. So I don't think there is anything wrong with our radios or specific to our cars. With it happening to so many others, the EXACT same thing- (There is a pretty long thread on it on one of the Jeep Wrangler forums)

It HAS to be an issue on the Sirius/Uconnect side.

I have heard from several others who have gone to the trouble of taking car to the dealer for service and not a single one had any success.

Some have reported being told by Uconnect that they are aware of it and some sort of over the air fix would be coming at some point. I'll believe it when I see it, but I feel like that is the only thing that is going to fix this- not getting any kind of repair or radio replacement.

Hopefully the fix will come soon........
We're sorry to hear that you are experiencing this concern. If you would like any additional assistance, our team is always available via private message!

Alison
JeepCares
 
1 - 7 of 7 Posts
Top