Jeep Garage  - Jeep Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 · (Edited)
hi folks, since I took delivery of my 14 Ltd, I am able to feel a jerk whenever I shift from park/drive/Neutral to Reverse... I searched and found that it is reported in earlier models as well. The jerk comes even after the engine has warmed up and is not in the initial high RPM's... I also hear a clicking noise when I shift.. Is that normal? Lastly, I am also experiencing the odd "shudder" when it feels as if enough fuel is not flowing to the engine and it takes a second to feel the acceleration...This is in ECO mode. Yet to experience it in SPORT. I am taking mine in to the dealership tomorrow... Anyone else facing this on their 2014 WK2s? l
 

·
Registered
Joined
·
311 Posts
I noticed on mine 14 summit, the same off "shudder" in sport mode when I'm coming to a stop, like it was late getting back to 1st gear, I can feel on my break pedal as I'm stopping... that's the only weirdness I have right now, no issues on regular Drive mode or to shift from P, to N, R, D...
 

·
Registered
Joined
·
8 Posts
I too feel like there is a very slight lurch when putting in to Drive - feels like the transmission is just engaging. My problem is a really rough 1st to 2nd gear shift. Not so much under strong acceleration but more apparent if I need to let off gas around the shift to 2nd gear. Feels like the car is getting kicked in the rear - not very refined feeling for a 40K plus suv. Anyone else having this issue?
 

·
Registered
Grand Cherokee
Joined
·
21 Posts
I have the 2012 Laredo V6 and it drives very inconsistently. One day it will be driving smooth and the next day I can be pushing the gas and it revs up but doesn't accelerate fast at all. Only after pushing the gas for a good amount of time it shifts gears and accelerates. Also I notice some harsh shifts in gears especially between 20-30mph
 

·
Registered
Joined
·
563 Posts
I have the 2012 Laredo V6 and it drives very inconsistently. One day it will be driving smooth and the next day I can be pushing the gas and it revs up but doesn't accelerate fast at all. Only after pushing the gas for a good amount of time it shifts gears and accelerates. Also I notice some harsh shifts in gears especially between 20-30mph
I also noticed this with my 2014 limited, but thought perhaps the transmission just needed to learn my driving style. One day it seemed to rev a bit before it "caught" and took off. Of course, my vehicle is having other issues, including a service 4wd system message, so it could be related...
 

·
Registered
Grand Cherokee
Joined
·
21 Posts
I just went over 30,000 miles I had the malfunction light come on once and I didn't notice any issues. Brought it to the dealership and all they did was some computer update and it was fine after that. The light came on around 15,000. Just under 10,000 I had a scary experience when I was driving on the highway and the transmission shifted into Neutral I had to pull over and restart the truck. Thankfully that only happened once. Other than that It has been problem free the only thing I dislike is it's inconsistency in performance. If there is anyone out there that has fixed the issue with the poor acceleration almost feels like the transmission is confused please answer I would love to hear what you guys did!
 

·
Registered
Joined
·
563 Posts
I just went over 30,000 miles I had the malfunction light come on once and I didn't notice any issues. Brought it to the dealership and all they did was some computer update and it was fine after that. The light came on around 15,000. Just under 10,000 I had a scary experience when I was driving on the highway and the transmission shifted into Neutral I had to pull over and restart the truck. Thankfully that only happened once. Other than that It has been problem free the only thing I dislike is it's inconsistency in performance. If there is anyone out there that has fixed the issue with the poor acceleration almost feels like the transmission is confused please answer I would love to hear what you guys did!
There is a recall for that very issue right now on the Grand Cherokees up to 2011 I believe... (Popping into neutral while driving)

Edit: never mind, didn't notice you had a 12
 

·
Registered
Grand Cherokee
Joined
·
21 Posts
I honestly think the 11 and 12 are the same wouldn't be surprised if they have the same problem... It only happened once I'm not too worried about it. I have more interest in the inconsistency in performance
 
1 - 8 of 8 Posts
Top