Jeep Garage  - Jeep Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1 (Edited)
When I went to drive my 06 WK, 3.7, 4x4 and as I began driving, I noticed the rpm's climbing and it did not shift, and seemed like it was 'stuck' in whatever gear it was in. The 'autostick' had no response either. I do not believe it was in limp mode, because only the [D] was lit up. But like I said, when I went to manually switch the gears with the 'autostick' - It would not move out of [D]. It would not manually shift to : [4], [3], [2] or [1].

I pulled over and turned the engine off for a minute. When I started it back up, everything seemed normal. You would never know that something was potentially wrong a few moments prior. For the most part, it drives fine, but it has done this twice in as many days.


No CEL/MIL have came on. For the heck of it, even though no lights came on, I used my scan tool and pulled codes: P2767 and P0710. Very strange, since no CEL came on! I do not know if these are old stored codes, and I'm leaning towards they are not. I just had the Shift Bezel/ESM replaced and I'm sure the dealer cleared all codes.

Any help, advice is greatly appreciated!! Thanks for reading and/or replying!!!

-Tom
 

·
Registered
Joined
·
66 Posts
Discussion Starter #2
Today, I cleared the stored codes, so we'll see what happens. So far, everything has been good today, no problems.
 

·
Administrator
2018 Jeep Trackhawk
Joined
·
56,922 Posts
hopefully just a hiccup...but ti sounded like the shifter
 

·
Registered
07 Grand Cherokee
Joined
·
107 Posts
I'm having the same problem with my 07 3.7. Sometimes if I put the shifter into drive the Jeep lunges and all the symbols are lit [P][R][N][D]. Now if I sit there for a second it stops and just the [D] is lit and everything is fine. I've also been caught driving at a low rate of speed and all the shifter lights suddenly light up and I'm in Limp mode. Usually just pulling over, shutting the car off, and restarting it fixes the problem.

This is my fourth jeep and the seventh between me, my wife, and brother. This WK has given me more problems than any of my others. It's very disappointing.
 

·
Registered
Laredo
Joined
·
300 Posts
I have 2009 3.7 just had this problem last week, on highway at 120 and then all of a sudden down to 90 km/h and when i press gas its very very slow to get up and it maxes out a 100. but the more you slow down once the gears lower you cannot go back to higher gears, so no gear change! it came and went 2 times until then realized i had a serious problem so brought to dealer and they scanend it and it was some P code from trnasmission, they have since serviced my car under powertrain warranty and they changed a few parts in my tranny, now seems to be working fine! the service guy told me its in part the electronics in the shifter that breaks and that follows it right into tranny where they have to change a chip or something! oh and yes you will need to change it, it will not dissapear!!!!

to stop this issue when you are driving... just put into neutral stop the car and turn off, put back into park, restart and there you are!
 

·
Registered
Joined
·
66 Posts
Discussion Starter #6
UPDATE: Problem Solved!! The lead frame assembly, containing the input speed sensor and a few other sensors, had to be replaced. The lead frame assembly contains wires and a circuit board. The valve body had to be removed, so obviously this involved a trans filter and fluid change, too.

Luckily, all this was covered by warranty.
 

·
Registered
Laredo
Joined
·
300 Posts
^ what i sead haha! atleast you have it all figured out!!!! and fixed!
 

·
Registered
07 Grand Cherokee
Joined
·
107 Posts
Unfortunately I'm outside of the warranty range. 119,000 Miles. Can of gas and a book of matches here I come.
 

·
Registered
Joined
·
66 Posts
Discussion Starter #9
Unfortunately I'm outside of the warranty range. 119,000 Miles. Can of gas and a book of matches here I come.
Are you absolutely positive, about that? I could be wrong, but I was under the impression that some 2007 WK's had a LIFETIME powertrain warranty!!

Have you talked to the dealership? You can also contact JEEP customer care to verify. I think if it was made on or after July 2007 (Don't hold me on that), then you may have coverage!!

If not, you might as well get ready to come off around a grand (Please toss the matches and gas, :))

Check this out, too: Jeep - Jeep Life - News - New ‘Best-in-Industry’ Lifetime Powertrain Warranty
 

·
Registered
Laredo
Joined
·
300 Posts
that sucks! :(
 

·
Registered
4x4 LTD
Joined
·
236 Posts
This happened to me today on my 3.6 2014 GC WK2. I see another thread that there is a flash recall so I will go to service Tues. The tranny clunked then I could get nothing but gear 5 and no sport or paddle shifting and RPM stayed at about 3K but after 7 miles, I pulled over and stopped and everything normal.
 

·
Premium Member
Joined
·
11 Posts
Jeep grand shroky ,,2006 .. when try to turn on and off so meany time ,, it is works
i have to turn on and off 6 times to unstuck 3rd ,,,
I had changed change ECU with another friend jeep ,,, the problems solved ,,,,but with my ECU will the problem back again
Any solution form my problem
 

Attachments

1 - 13 of 13 Posts
Top