Jeep Garage  - Jeep Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
just picked up a new 2019 grand Cherokee and i got a check engine light already at 875 miles. so i took it to my local Jeep dealer and asked them if they could check it out. they had me come back the next day and drop it off first thing in the morning so they could look into the code. after the Jeep being there all day they contacted me and requested that i leave it over night because they were not able to find the problem causing the code. i spoke with the tech working on it and he said it was passing all of the diagnostic tests.and he couldn't find any loose/ failing connections. He said he tested the pcm it passed testing and also tested the multi axis acceleration sensor module, it passed also. so he is requesting me to leave it so he can further diagnose this issue. my searches have not turned anything up on this issue and was wondering if anyone else had this and what did they do to correct the code. Thanks
 

·
Premium Member
Joined
·
1,345 Posts
well, the PCM has very little to do with that code, so the tech is right on the ball :(

hope they sort it out in finite time..
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
Got the Jeep back today, they are going to replace the multi axis acceleration sensor. they ordered it today and should have it by Monday. they asked me to bring it back on Tuesday to make this repair. So i will see what happens Tuesday.
 

·
Registered
Joined
·
1,596 Posts
just picked up a new 2019 grand Cherokee and i got a check engine light already at 875 miles. so i took it to my local Jeep dealer and asked them if they could check it out. they had me come back the next day and drop it off first thing in the morning so they could look into the code. after the Jeep being there all day they contacted me and requested that i leave it over night because they were not able to find the problem causing the code. i spoke with the tech working on it and he said it was passing all of the diagnostic tests.and he couldn't find any loose/ failing connections. He said he tested the pcm it passed testing and also tested the multi axis acceleration sensor module, it passed also. so he is requesting me to leave it so he can further diagnose this issue. my searches have not turned anything up on this issue and was wondering if anyone else had this and what did they do to correct the code. Thanks
Hi whiteone19,
We're sorry to hear about your experience. Please keep us updated. If additional assistance is needed, we would be happy to connect you with a Case Specialist to assist.
Alex
JeepCares
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
The part did not come in to my dealer on Monday so i wasn't able to get it repaired today. the service tech called me tonight and said the part had arrived late today. he said he could get me in to do the repair Thursday if i could get it to him. of course i agreed and i will see how it goes on Thursday. i will update if this fixes the U0432 code
 

·
Registered
Joined
·
1,596 Posts
The part did not come in to my dealer on Monday so i wasn't able to get it repaired today. the service tech called me tonight and said the part had arrived late today. he said he could get me in to do the repair Thursday if i could get it to him. of course i agreed and i will see how it goes on Thursday. i will update if this fixes the U0432 code
Hello whiteone19,
We are happy to hear you are working alongside your dealer to rectify your concern. If you would like any additional assistance throughout this process, please feel free to send us a private message and we'll be happy to help.
Laura
JeepCares
 

·
Registered
Joined
·
16 Posts
Discussion Starter #8
update: the multi axis acceleration sensor was replaced and so far seems to be the source of my problem. it seems to be working perfectly. no more pending codes and no more codes. this was covered by warranty and was no cost to me. i will keep an eye on it and update if anything changes. while it was at the dealer the repair tech noticed there was a software update on my radio system and asked if he could install it while he was there. i agreed and now it has updated software to 28.3. he also done this at no charge to me. turned out to be very good dealer experience for me, it was more than i expected for sure.
 
1 - 8 of 8 Posts
Top