Jeep Garage  - Jeep Forum banner
121 - 140 of 141 Posts

·
Registered
Joined
·
3 Posts
Got it, thanks for the input. So my radio is currently bricked like everyone else after trying to upgrade to 18.4. I have an apt at the dealership on Monday but not really sure how much help they’ll be. Has anyone tried downloading a little bit of an older software (something older than 18.4) and trying to insert that on a thumb drive when the screen prompts you to? Just trying to think of a way to get the screen back to normal and Uconnect up and running again.
 

·
Registered
Joined
·
3 Posts
I joined this problem yesterday with my 2014 jeep GC. As many of you, I called uconnect and was told that dealer is the only option. My unit fails on step 11 of 15, when it attempts to update the wireless card. At the dealer now...
 

·
Registered
Joined
·
3 Posts
I was actually able to fix this problem by plugging the USB back into my computer, erasing the whole drive, reformatting the drive to FAT 32 and then re-uploading the software. I let it go overnight and came out in the morning and the radio was updated to 18.4.. Hope this helps!
 

·
Registered
Joined
·
2,112 Posts
I joined this problem yesterday with my 2014 jeep GC. As many of you, I called uconnect and was told that dealer is the only option. My unit fails on step 11 of 15, when it attempts to update the wireless card. At the dealer now...
Hey Thomas,

Feel free to keep us updated on the status of your dealership visit and let us know if you have any questions/concerns in the meantime. I hope they're able to get everything worked out for you!

Courtney
Jeep Cares
 
  • Like
Reactions: Thomas D

·
Registered
Joined
·
2 Posts
Hey Thomas,

Feel free to keep us updated on the status of your dealership visit and let us know if you have any questions/concerns in the meantime. I hope they're able to get everything worked out for you!

Courtney
Jeep Cares

Hello Jeep Cares. Not exactly sure just what you do to help, but I am desperate and need assistance. Like the previous author, I have a new yo me 2014 Cherokee Trailhawk that I was trying to update from 17.11.07 to 18.45.00 with the assistance of a Uconnect representative. We spent over an hour booting and rebooting with the USB info downloaded from Chrysler Jeep per three instructions. After maybe a dozen tries, the screen went blank white and just kept asking for the USB which was already in it. The last Uconnect rep I spoke to, said the problem is that I bought a used car and got all the inherent problems that come with them. Goodbye!

I do have an appointment now to be looked at, but have little hope yet.

Herman H
 

·
Registered
Joined
·
2 Posts
I joined this problem yesterday with my 2014 jeep GC. As many of you, I called uconnect and was told that dealer is the only option. My unit fails on step 11 of 15, when it attempts to update the wireless card. At the dealer now...
I had the exact same problem. I retried it like 10 times at least. Finally took the unit out of the dash to give it a hard reset. I let it sit for about an hour then plugged it all back in. The software upgrade went through on the next try. My nav still doesn't work but everything else is back to the way it was thank goodness.
 

·
Registered
Joined
·
2 Posts
It says my nav needs to be calibrated and to drive around town. I drove around town but it's still saying the same thing. At this point I don't care, I'm just glad I don't have to buy a new head for 1500 bucks.
 

·
Registered
2014 Grand Cherokee
Joined
·
1,246 Posts
It says my nav needs to be calibrated and to drive around town. I drove around town but it's still saying the same thing. At this point I don't care, I'm just glad I don't have to buy a new head for 1500 bucks.
Don't count your chickens yet. If the NAV doesn't come back, you probably will need a new head unit unless you have the RA3, in which case, NAV might be salvageable.
 

·
Registered
Joined
·
3 Posts
Hey Thomas,

Feel free to keep us updated on the status of your dealership visit and let us know if you have any questions/concerns in the meantime. I hope they're able to get everything worked out for you!

Courtney
Jeep Cares
The local dealer was not able to correct the update. They contacted Uconnect, but as of today, have not received a call back.

Still waiting...
 

·
Registered
Joined
·
2,112 Posts
Hello Jeep Cares. Not exactly sure just what you do to help, but I am desperate and need assistance. Like the previous author, I have a new yo me 2014 Cherokee Trailhawk that I was trying to update from 17.11.07 to 18.45.00 with the assistance of a Uconnect representative. We spent over an hour booting and rebooting with the USB info downloaded from Chrysler Jeep per three instructions. After maybe a dozen tries, the screen went blank white and just kept asking for the USB which was already in it. The last Uconnect rep I spoke to, said the problem is that I bought a used car and got all the inherent problems that come with them. Goodbye!

I do have an appointment now to be looked at, but have little hope yet.

Herman H
I'm sorry to hear about the experience you had with your previous customer service representatives while trying to get this properly addressed. Please follow up via private message with your VIN so I can begin the process of getting additional support arranged for you. Thanks, Herman!


The local dealer was not able to correct the update. They contacted Uconnect, but as of today, have not received a call back.

Still waiting...
Hey Thomas--

I'd be happy to work alongside your Uconnect Specialist and dealer! Please send us a private message with your current case number and/or VIN to get started.

Thanks,

Courtney
Jeep Cares
 

·
Registered
Joined
·
3 Posts
I'm sorry to hear about the experience you had with your previous customer service representatives while trying to get this properly addressed. Please follow up via private message with your VIN so I can begin the process of getting additional support arranged for you. Thanks, Herman!




Hey Thomas--

I'd be happy to work alongside your Uconnect Specialist and dealer! Please send us a private message with your current case number and/or VIN to get started.

Thanks,

Courtney
Jeep Cares
Thank you for the exceptional responses. I am happy to say, that this morning I went into the Jeep and the JEEP logo appeared on the Radio.. I was absolutely shocked. I don't recall if the USB drive was in our out, but I have removed the drive from the vehicle to make sure I wouldn't attempt to use it again. I didn't do anything except that I kept a battery maintainer connected to the vehicle, to make sure the battery did not die. The update took 6 days in total, and now appears fully functional.

I do not currently have uconnect, but did receive a notice that "MY unconnect registration has been removed, and the radio will reboot shortly"... it rebooted, and still working....

Happy to have Air Condition and Backup camera again....

Thomas
 

·
Registered
Joined
·
2 Posts
Got it, thanks for the input. So my radio is currently bricked like everyone else after trying to upgrade to 18.4. I have an apt at the dealership on Monday but not really sure how much help they’ll be. Has anyone tried downloading a little bit of an older software (something older than 18.4) and trying to insert that on a thumb drive when the screen prompts you to? Just trying to think of a way to get the screen back to normal and Uconnect up and running again.
Old&Tired here and now even more so. I had my 2014 Cherokee appointment on 5/17 and as expected they charged me $130.00 to tell me that the radio is toast and useless after nothing more than attempting to update to 8.4 as the radio asked. However, for a mere grand and a half, I can have a new one. Not happening at all but so much doesn't work in the car without it. Infotainment.com makes the original defective units so I went to their site and found that they generously will repair and update for $298.00 to start (prepaid) and then return to you. And so I did and shipped via UPS 2 day Air. for $100 since I am in immediate need after 2 weeks of no use at all. On Wednesday I found that UPS has sent it somewhere else and it is now lost in Lexington KY. So much for UPS 2 day and its expense! UPS tells me it was their mistake, but they don't refund for those errors. Now, I am awaiting their finding my radio and then continuing the trip to Florida for the Infotainment delivery and eventual repair. Somehow does this all seem to be a money grabbing conspiracy by Chrysler and their chosen partners?
 

·
Registered
Joined
·
2,112 Posts
Thank you for the exceptional responses. I am happy to say, that this morning I went into the Jeep and the JEEP logo appeared on the Radio.. I was absolutely shocked. I don't recall if the USB drive was in our out, but I have removed the drive from the vehicle to make sure I wouldn't attempt to use it again. I didn't do anything except that I kept a battery maintainer connected to the vehicle, to make sure the battery did not die. The update took 6 days in total, and now appears fully functional.

I do not currently have uconnect, but did receive a notice that "MY unconnect registration has been removed, and the radio will reboot shortly"... it rebooted, and still working....

Happy to have Air Condition and Backup camera again....

Thomas
Oh awesome-- that's great news, Thomas! I'm glad to hear that everything is back to normal and working well again. Please keep our team in mind, should you run into any questions or concerns in the future. Have an amazing weekend!

Courtney
Jeep Cares
 

·
Registered
Joined
·
1 Posts
Hello Team Members,
As some of us have some problems with updating uconnect 8.4AN, I describe my problem:

1. I downloaded update 17.43.01 - UCONNECT_8.4AN_RA4_17.43.01_MY15_NAFTA
2. Inserted with engine on running USB sticker 16GB, clean, with 2 unpacked files
3. Radio asked me if I want to make update, so yes
4. I encountered the error (around 67% of total update) “Sierra Wireless: bolo file install failed”. The update process went smoothly up until Unit number 10. Unit Name: Embedded Air Card, the process was stuck at 1%, and eventually timed out with the error “Sierra Wireless: bolo file install failed”.
5. After the Failed Uconnect 8.4 Software Update, the update process would loop while the USB flash drive was inserted. When I removed the USB flash drive, I was constantly prompted to "Please Insert Update USB". It appeared the failed Uconnect update had bricked my Uconnect 8.4.

I tried as some suggestions:
1. Remove USB Drive while Uconnect is checking the integrity of the ISO (during Pre-Update ISO validation)
2. Remove car battery

Any ideas how to take it back to run? I don`t think that ASO will change my radio for free because is not under warranty now. But they might have some extra procedure for this?

I did not inserted any pictures but this is exactly what is here:
Recover a Bricked Uconnect 8.4 after failed update | Lancelhoff

Please help and thank you.

Radek
Hello new here. Had same issue. What worked for me was to disconnect battery and touch terminals together for a few seconds. This drains the capacitors that hold memory etc…. Then reconnect then update, then it gets past unit11 !!!!! Yeah.
 

·
Registered
Joined
·
1 Posts
Hi everyone I researched and found this page as was having the initial issue of the 2015 Durango uconnect saying phone needs updated and then the entire computer blacking out not allowing climate control or radio to function. I had found the uconnect was pretty out of date and so my first step was to get that updates installed. Like many on this post I ran into the issue of it failing on step 11 and timing out. What I found after reading through the posts the one thing I noticed was everyone who took the radio out and disconnected and reconnected the cable then proceeded with the update it worked. That was the set of steps I took after trying the update 4 times and driving around etc with no luck. After taking the radio out and taking those steps the very first time I ran the update it went through the first time still sitting in the driveway where it failed several of those times. I agree with others forget all of this other stuff, driving around, disconnecting battery etc. just follow those steps which took about 15 minutes to take radio out and put back in and It seems to solve problem.
 

·
Registered
Joined
·
1 Posts
Hi everybody, I’m a Challenger owner that stumbled on this thread googling around looking for a solution to this problem. Same issue as everyone else, update fails at Unit 11 Airstream card and then death loop. I tried every trick I found online (yanking the USB stick at a certain point, etc) and nothing worked. As a last ditch effort I took the radio out of the car and opened it.

All I did was disconnect and reconnect the wire for the Airstream card. After doing this and reassembling the radio the update ran with no problem. Someone mentioned this above and I wanted to provide some more details.

If you’re at all familiar with replacing a wifi card in a computer then you’ve seen this kind of cable before. It’s really simple.

I didn’t take pics because I didn’t know if this would work at the time, so I made a crude diagram. Here’s what you need to do:

1- Remove the radio (there are youtube videos for this)

2- Open the radio by removing 4 torx screws. Sorry I didn’t note the bit size. I tried to notate where these screws are here (my marks in green). Gently pull this back part straight up. You’ll see the cable you need. Be careful not to go too fast and break it.
View attachment 232200

3- Adjust the Airstream cable. In this diagram the Airstream card is on the left, it will have an Airstream logo on it. The small connection next to it is just a snap connector. Just press on it gently to make sure it’s seated properly.

The other end of the cable pushes into the other card/box/whatever shown on the right. It pulls out in the direction I noted. I just pulled this out and put it back in and made sure it was in all the way.
View attachment 232201

4- Reassemble everything and try the update again. When I did this the Airstream step was a little slow but it got past 1% pretty quick.

Hopefully this helps.
Thank you very much for this. This worked for me, first try. I wish I had skipped to page six, I drove all over the damn town watching the screen freeze up at 11. This was very easy, the bezel just pops right out. I did it at night with a flashlight, and it still didn’t even take as long as the update itself.

Anyone new to this thread, if you’re reading this, sorry, you obviously have the same issue as so many of us and it’s too late to just leave it alone, but follow the steps JJBBQ laid out and forget about trying 30 times to install the update. Never mind disconnecting the battery or reformatting your flash drive thingy. I don’t know what it did, but it worked, and now I won’t have to listen to the wife gripe about nothing working in the Jeep.
 

·
Registered
Joined
·
1 Posts
Grand Cherokee, My bricked radio story started one week ago. Had the 'contact dealer phone connection jacked' message and have had no GPS/Nav for two years. Contacted Uconnect last Friday, downloaded the software to 128MB flash drive, upload got stuck at Unit 11, 1%, like every one else. Nope, must use, 4 to 16GB flash drive only. recos to not use SanDisk, but I bought a SanDisk and generic 16GB FD. Drove around, went to the cell towers, nope. Took out the radio, unhooked, rehooked all connections, nope. No upload, always stuck on Unit 11, 1%. Safford Jeep in Spfld has a Great Serv Dept. They knew of the issue, said they could try the upload there. All the while I had to keep disconnecting the pos battery connection under the hood, cuz the screen was stuck in ON position and didn't want the battery to die.
Left the Jeep at dealer overnight. They called next morning to tell me to come pick it up, they couldn't get the upload to take. I was leaning toward an after market Sony radio etc. Still talking to Uconnect and I told them I read that Uconnect will pay for a new radio. They said if the dealer could not do the upload, they would pay for a new radio, labor included. Uconnect confirms with dealer that upload isn't working. New radio ordered. I'm told it could be 2 days to 3 weeks, no way to tell, this was Wed. Thus, dealer calls me and says, the radio is IN and wants to know what I said to Uconnect, lol.
Thurs evening, I drive back to dealer, upload is still going on. As I pull into the service bay to leave the vehicle, the upload gets completed!!! Nav/GPS, everything now Works. Dealer says to still leave it and they will put in a newish radio, as it will have a 2 year warranty. None of the suggestions to un-brick the radio worked for me. After, 10 to 15 attempts to do the upload it finally did go through. But, too little too late as I'm getting a new radio. However, if you don't want to do all the back n forth with Uconnect and the dealer, just keep trying. Like everyone else on here, it seems like the upload will eventually go through.
I asked the dealer as to why this problem has been ongoing for at least 6 years. They said Uconnect does the software and United Radio does the hardware. Neither party will agree on a fix, so we all pay the price.
Lastly, I do not recommend trying to do the upload, unless 1. you want to go through this gauntlet of hassles, or 2. you are a glutton for punishment, or 3. you can't live without the GPS. In hindsight, I would have never tried this, if I knew what I'd be going through. But, in the end, I did get a new radio. Thanks
 

·
Registered
2014 Grand Cherokee
Joined
·
1,246 Posts
One thing is that you should disconnect the negative terminal to the battery, not the positive as disconnecting the positive first can sometimes result in sparking which can result in damage to electronics in the system.
 

·
Registered
Joined
·
1 Posts
Not sure if this has been mentioned in this forum. So if you are getting the "BOLO" Warning and your 8.4 is bricked, there is an easy fix for this..... Bring your car to a main road. Somewhere that 3G service would work. Run the update. In this step, the system checks for the "Onair" update. If it does not detect a 3G network. It will fail. I did not believe this theory, drove it to a Walmart parking lot and wholla! it worked. Since then my Radio Occasionally takes a while to boot up. It's still not perfect, but usable. I believe they invented these with a reliance on 3G or some communication, if it is not there, the system chokes. I wish they could update the firmware so it could just be used as a regualar radio - minus the Chrysler cares app for service/911, I believe this is the root of the issue and there are no issues with the radio itself, just a communications issue with the mother ship Chrysler/Mopar.
Since I performed a factory reset. It sort of works better, but still an occasional long startup, but the GPS thinks I am a state away. Again not the right communication configuration since it at some point updated. I may try the update again, but I am sick of dealing with it as it's the only crappy thing on my Jeep. I read Uconnect is updating systems again for the new model year. I am sure this will make older Uconnect systems even more incompatible.
 
121 - 140 of 141 Posts
Top