Jeep Garage  - Jeep Forum banner

1 - 6 of 6 Posts

·
Premium Member
Joined
·
29 Posts
Discussion Starter #1
Sorry if this has already been brought up....

2014 overland, bought 6 days ago. I plugged my iPhone charger into the USB this morning and uconnect went berserk. The screen went dim and I was locked out of all controls. I couldn't access any screen, turn the volume up down or mute. Nothing else was accessible either. I pulled the USB, turned the car off and on several times but it didn't resolve. I let it sit off for 30 mins and it fixed it, but I did have to pair my phone again.

Is my USB port useless or what? :confused:
 

·
Registered
Joined
·
375 Posts
I don't know why it would do that...but....I did notice that there are two USB ports designated in the manual as USB Charging Ports on the back of the center console as seen from the back seat.
 

·
Registered
Joined
·
6 Posts
I've had similar issues with my system locking up and then being unable to use any of the other features. Really hoping there's a way to "reboot" it without having to stop, turn it off, and wait.
 

·
Registered
Joined
·
3 Posts
Maybe your USB cable has a short circuit in it. The wires in these are very small guage wires and can break easily. I'd try another USB cable. This only happened to me once when I was traveling in an unfamiliar place using Android Auto, so I lost the navigation screen and had to use the phone screen to navigate. After sitting for a few hours uconnect was OK.
 

·
Registered
Joined
·
1,453 Posts
That Iphone charger could have issues like over drawing charging current or its remotely possible the Uconnect was trying to read that charger and went into Lala land.
I would try a generic 3rd party charger and see what happens.
If the Uconnect cannot read your music USB thumb drive Its possible that the thumb drive revision you're using is not compatible with your Uconnect system.
 
1 - 6 of 6 Posts
Top